Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Import Mapper Halp

edited January 6 in Troubleshooting

Hi all,

I have been fighting with getting this import mapping working all day, and I have managed to get everything working except the storage locations. This series of records is stored by series and box. The boxes are labeled as series-box (i.e. 12-0001). It should be that the idno of the series is the series number, and the idno of the box is series-box number. The mapper is properly parsing the box numbers into the hierarchy and properly creating the storage locations (they show up in Find > Storage Locations > Browse); however, it is assigning a box idno of just the box number. (Example: for box 12-0001, it should spit out a series with idno 12 and preferred_label of Series 12 and a box with idno 12-0001 and preferred_label of Box 12-0001.)

I'm assuming that it is something to do with the refinery parameters to specifically set what to use as the box idno, but I am stumped as to what it is.

However, even if I manually change the box idno for each box to the proper format, the mapper does not set the proper location. Is there some other thing I have to specify after ca_objects.ca_objects_location?

I have attached a data sample and the mapper.

Yours,
Chris Litfin

Comments

  • Hi Chris, The idno for series needs to be wrapped in the attributes setting, like this:

    {
    "relationshipType": "related",
    "hierarchicalStorageLocationTypes": ["series", "box"],
    "hierarchicalDelimiter": "-",
    "matchOn": ["idno"],
    "attributes": {
    "idno": "^14"
    }
    }

    I just tried it with your data and it works.

    Jonathan

Sign In or Register to comment.