Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

OpenStreetMaps in Pawtucket

Hello,

I am trying to change from google maps to OpenStreetMaps in Pawtucket, but I cannot get this to work.

I have added the following to /pawtucket/app/conf/app.conf

 #mapping_plugin = GoogleMaps
 mapping_plugin = OpenLayers

I have also tried adding the options given in a previous discussion.
(https://collectiveaccess.org/support/index.php?p=/discussion/293190/openlayers-in-pawtucket/)

When I use GoogleMaps, maps appear and work as expected.
But with the changes above, no maps appear.

I am not getting any error messages displaying.
(/pawtucket/setup.php has "define('CA_ENABLE_DEBUG_OUTPUT', true)". Are there any specific log files I should be checking?)

Any suggestions on what I am doing wrong, or anything I need to make sure has been installed to make this work?

[I am using: Providence 1.7.5; Pawtucket2 1.7.5; PHP 7.1; Centos 7.6]

With thanks,
Clifford.

Comments

  • What do you see? Nothing at all? Or a broken map?

  • Hi Seth,
    Nothing at all.

    This is with google maps:

    This is with Open Street Maps:

  • Is the OpenLayers plugin present in app/lib/Plugins/GeographicMap ?

  • This one?
    (Slightly different path...)
    [...]/pawtucket/app/lib/core/Plugins/GeographicMap/OpenLayers.php

  • Yes, so that's not the problem. Can you send me your app.conf file?

  • Thank you, Seth: I'll send it to your collectiveaccess.org email.

    Looking around github I found "NOJIRA add OpenStreetMaps":
    https://github.com/collectiveaccess/providence/commit/aed377b529e7800bc4f6d6c9c02597dc849676dc
    That is in Providence, but could it help?

    Another thought: is this something that my organisation's firewall might be interfering with? (But googlemaps works fine...)

  • edited February 13

    I have the same problem. My browser says:

    Uncaught ReferenceError: OpenLayers is not defined
    at HTMLDocument.<anonymous> (11:209)
    at fire (jquery.js:3048)
    at Object.fireWith [as resolveWith] (jquery.js:3160)
    at Function.ready (jquery.js:433)
    at HTMLDocument.completed (jquery.js:104)

    As I thought, it is not defined, like GoogleMaps. But where can we define it?

    I tried it also with
    mapping_plugin = leaflet or
    mapping_plugin = Leaflet
    but then I get a error message that Leaflet doesn't exist although I use it without problems in providence.

  • Current versions of CA use Leaflet. OpenLayers was left in for those who still wanted it, but we're not supporting it and it's likely broken.

    Leaflet definitely works in Pawtucket. Make sure you're running an up-to-date installation.

Sign In or Register to comment.