Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Importing to an existing storage location

Hi,
I have an hierarchical storage locations setup in my ca instance. The highest level being the building with an id of 1.0. Room ids are at the next level down i.e 1.1, 1.2 ,1.3 etc. I have been trying to import objects that are stored in a room Lecture Room with idno 1.9 and have used the following refinery in my mapping -
{
"relationshipType": "related",
"matchOn": ["idno"],
"ignoreParent": "0"
}
The relevant column in the data source is set to 1.9
I get no errors on running the importer but storage location in the imported data is empty. I am obviously doing something wrong but unable to pinpoint what . If I change "ignoreParent":"1" I get the same result. Any advice would be welcome.

Comments

  • After going through past posts i found someone who had a similar problem which appeared to be solved using a more detailed refinery. I modeled ny refinery on the example but when I run the importer everything works except for the allocation of the objects storage location. I do see that the number of storage locations reported in counts increases by the number of records imported and also if I look at the Storage Location Hierarchy I see a ling list of closed brackets under the level 1 building list. I have included a copy of my mapping for reference - help would be appreciated.

  • You need to set your refinery column to storageLocationSplitter.

  • Hi Julia,
    Thank you for the information - works fine now. A case of tunnel vision again.
    Eric

  • Glad it's working for you

Sign In or Register to comment.