Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Dimensions decimal point

edited February 2019 in Troubleshooting

Software version: Providence 1.7.6

Profile: An adaptation from the SPECTRUM profile

In Providence 1.7.5 I entered dimensions with units like 40,5cm.They then appeared as such after saving.
In Providence 1.7.6 they appear as 40 5cm (Sometimes 40 5 cm)
Where is the decimal delimiter set? It appears to have changed.
It works if I use a point as decimal point, it puts in a space when I use a comma as decimal point.

Comments

  • What are you preferences set to under Manage > My Preferences > Units of measurement?

  • I have "units as entered" set at the moment. Have also tried "metric".
    I have tried entering:
    12,5cm
    12,5 cm (with a space between the value and the units)

    I have three setups running, on locally and two online to see the difference in settings, but I have not found a solution yet.
    One thing I have tried is changing the setting "does not take locale" for the dimensions, also with no result.
    The behaviour has definetely changed from version 1.7.5 to 1.7.6
    I did notice the same behaviour in your demo (demo.collectiveaccess.org)

  • One more observation: With weights it works as before.
    If I enter either 2,3kg OR 2,3 kg it is displayed in the object editor as 2,3 kg after saving.

  • One more observation:
    The comma is stripped in the table ca_attribute_values. I checked with phpmyadmin.
    In version 1.7.6 a value 17,5cm is stored as 17 0cm after save

  • We are seeing the same issue, on a custom profile, it does look like a 1.7.6 bug/regression.

  • Could you please make a JIRA for the issue? http://clangers.collectiveaccess.org/jira/

  • It would be my first time. Hope I gave all the nececarry info.
    clangers.collectiveaccess.org/jira/browse/PROV-2652

  • edited May 8

    Hi. I am having another kind of problem (CA v 1.7.8) : when importing measures, in Italian locale, every decimal separator is parsed as a sum...
    I mean: 10,5 get parsed and inserted in measure field as 15, the same with a dot as decimal separator: 10.2 -> 12.

    Things get better by setting English as default locale, but only with a dot as decimal separator.

    I am using this measurementSplitter:
    "{
    ""delimiter"": ""x"",
    ""units"": ""cm"",
    ""elements"": [
    {""quantityElement"": ""dimensions_height""},
    {""quantityElement"": ""dimensions_length""},
    {""quantityElement"": ""dimensions_thickness""},
    {""quantityElement"": ""dimensions_thickness""},
    {""quantityElement"": ""dimensions_thickness""}
    ],
    ""attributes"": { ""measurement_notes"": ""^9"" }
    }"

    Obviously, the value I am parsing is something similar to 8.5x0x1.5

    Any hint?

    Also, is there any way to skip a value without setting it to zero? - i.e. some thing like 8.5x x1.5 ?

    Thank you,

    Giovanni

    I add the parsing log of following values
    Frammento 1 14x7,5x2,8 Frammento 2 8.5x0x1.5

    using previous measurement splitter:

    2020-05-08 10:30:48 - DEBUG --> Content tree is
    Array
    (
    [ca_objects] => Array
    (
    [0] => Array
    (
    [dimensions] => Array
    (
    [dimensions_height] => 14 cm
    [dimensions_length] => 12 cm
    [dimensions_thickness] => 10 cm
    [measurement_notes] => Frammento 1
    [_errorPolicy] => ignore
    )
    )
    [1] => Array
    (
    [dimensions] => Array
    (
    [dimensions_height] => 8.5 cm
    [dimensions_length] => 0 cm
    [dimensions_thickness] => 1.5 cm
    [measurement_notes] => Frammento 2
    [_errorPolicy] => ignore
    )
    )
    )
    )

Sign In or Register to comment.