Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Importing hierarchical storage location.

Hi,
I have been through the discussions and looked at various solutions offered but still not getting it right. The first time I ran the import using the test import it ran with no errors so I tried an actual import which also ran with no errors but nothing was imported at least not to where I would have expected the results to be. I have attached my data source and my mapping for advice on what is going wrong - help would be appreciated.
Ubuntu 16.04 Providence 1.7.6

Comments

  • You're missing: Rule Type, Source and CA table.element in row 1
    Mapping 13 ca_storage_locations.parent_id
    Also, the refinery should also be storageLocationHierarchyBuilder.

    You'll need mappings for the target of the import, shelves, as well.

  • Hi Julia
    Thank you for your response. I have included the Mapping in row 3 as I have rows 1&2 skipped so source 15 ca_storage_locations.parent_id and refinery = storageLocationHierarchyBuilder. Their omission was nothing less than gross negligence on my part. I have modeled my source data on Berny/Andy's posting but still get a clear import (no errors) but no storage locations added. I suspect that maybe my data source is not correct but cannot see why. Dry run is ok. I would have thought that shelves would have been picked up from the relevant hierarchical column
    Doooing something wrong so more help would be appreciated.
    Eric

  • Update - I saved the source data as .ods (something wrong in the xlsx version) and now I am getting results for storage locations - not all in the right place but at least I now have something to work with.

  • Location ^13 needs to be mapped as normal, outside of the refinery with individual mappings for ca_storage_locations.idno for 14, ca_storage_locations.preferred_labels (13) and ca_storage_locations.type_id (15). Then, the refinery source should be mapped to the name of the first parent above 13 so, 10-12.

  • Thank you kindly for your advice and patience. Before mapping ^13,^14 and 15^ separately I was getting ???(%) at the end of each of my storage location hierarchies. After mapping as you advised this disappeared from the hierarchy with the greatest depth but for all others I now get BLANK, is there a way of suppressing this?. {"skipifEmpty":1} in 13,14.15 seems to break the importer i.e it won't upload. The other reason I had locations in wrong places was that I was using 1.0,1.2,1.3.........1.30 as my location IDs and I had the ID columns in numerical format - the importer did not seem to recognize the difference between 1.2 and 1.20 and 1.3 and 1.30. I changed the formatting of these columns to "text" and it solved the problem. May help someone else. Thanks again for your time.

  • New Mapping and source files for above comment

  • Yes, the storageLocationHierarchyBuilder assumes you have a target for your base level and that you are building a hierarchy above that, hence the blanks.

  • Thanks Julia

Sign In or Register to comment.