Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Interstitials in 1.7.7

We are having problems with interstitials in 1.7.7, the popup gets an error message right after clicking on the paperclip (this is for objects x locations)

( ! ) Fatal error: Uncaught Error: Call to a member function getParameter() on null in /var/www/html/ath-museoa-1.7.7/app/lib/ResultContext.php on line 619
( ! ) Error: Call to a member function getParameter() on null in /var/www/html/ath-museoa-1.7.7/app/lib/ResultContext.php on line 619
Call Stack

Time Memory Function Location

1 0.0002 427400 {main}( ) .../index.php:0
2 0.2458 41663968 AppController->dispatch( ) .../index.php:122
3 0.2458 41663968 RequestDispatcher->dispatch( ) .../AppController.php:113
4 0.2593 43588592 InterstitialController->Form( ) .../RequestDispatcher.php:273
5 0.4020 51993736 ResultContext->getParameter( ) .../BaseInterstitialController.php:127

Adding a check for nullity for $this->opo_request in getParameter (line 612) in ResultContext.php avoids the issue, but that might not the underlying issue. ResultContext has popup up before in the context of the 1.7.7 upgrade, any ideas? Thanks

Comments

  • Similar problem in Providence v.1.7.8-
    Fatal error: Uncaught Error: Call to a member function getParameter() on null in /var/www/html/providence/app/lib/ResultContext.php:617 Stack trace: #0 /var/www/html/providence/app/lib/BaseInterstitialController.php(127): ResultContext->getParameter('ca_objects_x_oc...') #1 /var/www/html/providence/app/lib/Controller/RequestDispatcher.php(273): BaseInterstitialController->Form(NULL) #2 /var/www/html/providence/app/lib/Controller/AppController.php(113): RequestDispatcher->dispatch(Array) #3 /var/www/html/providence/index.php(120): AppController->dispatch(true) #4 {main} thrown in /var/www/html/providence/app/lib/ResultContext.php on line 617

    In v.1.7.6 it is working fine.

    Any help?

    Thank you

    Giovanni

Sign In or Register to comment.