Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

issue with symlink.

edited April 15 in Troubleshooting

hi, i'm having issues with one thing pretty much. IT at the university i'm working at created an external networkdrive for collectiveaccess to use for it's archiving/storage but linking to it is NOT working.
it is essentially a symlink and I thought i'd done it right. Apparently not. I would like to make sure the language is correct on what i'm doing.
this is the drive location: (/var/www/html/web/media/collectiveaccess/claData)
I am pretty certain that I do Not need to state it's a symlink anywhere in the media_volumes, just the link. is this correct?
I uploaded my files, just in case i've messed this up greatly. I would REALLY appreciate some help, thanks.

Comments

  • I am not 100% sure on the places to put the actual locations. I think that's my main issue. Everything was working until we tried to setup the reference to the external drive. Since then, it has not worked.

  • This is the little utility I wrote to manage my media symlink on a shared server without shell access.
    I left everything else as defaults pointing to the /media directory.

  • so this utility should fix my issues? thanks. will try it!

  • You will need to edit the pointer to the actual media directory. Be aware that many web based file managers used on shared servers do not indicate a symlink vs a real directory so it can get confusing.

  • for this "/home/users/web/b1269/ipw.pelhamhs/PHS_CA_Media" I just replace that with the link i'm trying to set it up with, correct?

  • Ok i'd like to be Certain I know what i'm doing here with this. Just import the file (with appropriate edits) into the providence root directory? Just clarifying here. thanks.

  • you will need to modify....or temporarly rename the .htaccess to allow it to run. also rename the utility as .php (it was renamed .txt to allow it to upload to the forum)

Sign In or Register to comment.