Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Exporting Profile Config

I thought that I had solved this problem but it seems to have come back again. I have been modifying a Dublin Core profile by adding new lists and metadata elements. To ensure that I did not have to go back too far if I made a mistake I exported the configuration after every few additions. On trying to reinstall CA using my profile I keep getting the error that my XML is not valid. I tried installing the Dublin Core and then without making any changes I exported the profile. Trying to install with the exported profile results in the same error. I tried the same exercise using the "base profile" and I get the same error. I tried validating both exported profiles using XML Copy Editor and got the same result " Error at line 43, column 29: no declaration found for element 'description". An extraction from the validator is shown below.

item idno='concept"enabled="1" default="1"
labels
label locale="en_US preferred="1"
name_singular>concept</name_singular
name_plural>concepts</name_plural
description/
This error appears in numerous places when trying to validate the file. Deleting every instance of this error results in a validated XML.
The only data in the database should be what the installer inserts i.e I have started with a clean database every time. I just cant figure out where the error is creeping in. Is it in the installation or the export process or am I trying to do something that is not supported in CA.
Using Ubuntu 16.04, Providence 1.7.6 schema 153
(apologies to Seth for repeating this here)

Sign In or Register to comment.