Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Fields lost in Data Importer import action

Hi, I'm testing out collective access for a catalog of datasets, where I want to import records for study variables, assign them a categorical designation, and relate them to their parent dataset, allowing users to search for variables by designation (medical history, physical assessment, etc.) across datasets. I tried to make a simple mapping document based on the data import tutorial document, with only variable name, variable description and category, but otherwise following the example document (also, gave type_id of 'document'). The mapping document is uploaded fine, and the batch processing of my excel spreadsheet with variable information works (ie. a record is created for each variable), but the descriptions are all blank and the 'subject' information (I gave the variable category as 'ca_objects.subject') is not imported.

I tried to do an even more simple experiment using the documents downloaded as part of the tutorial. In this case again, no description or subject heading information was imported. Can someone tell me where I'm going wrong? Beyond that, can someone point me to documentation about defining a custom object type (for variables and studies and etc) and selecting/defining its metadata fields? I'm greatly interested in the apparent customizability and data modelling capabilities of Collective Access, but haven't been able to find much through the wiki.

Thank you,
Andy

Comments

  • Are you sure the codes in the import mapping for description and subject match the metadata element codes in your system? Is subject a list and if so are you mapping the list items via Original Values/Replacement values? In terms of defining a custom object type and adding fields -- are you working through the GUI or installation profile?

  • Hmm, I'm afraid I don't know if the codes match. I simply took the tutorial template and replaced the given values with my own. Subject is not a list, again I just thought I was using it in the same was as shown in the tutorial. Re: custom object types, I'm currently working through the GUI but could use an installation profile as well (I think?). Sorry if these answers aren't terribly satisfactory, I'm very new to AC and system configuration in general, just spun up AC on a virtual machine and am poking around as part of a larger investigation of open-source cataloging/data presentation software.

  • You can change the object types through the GUI via Manage > Lists and Vocabularies > Objects types. To find the correct codes for the import mappings you can navigate to Manage > Metadata elements and look at the "code" column.

  • Wonderful, thank you so much for your help!

Sign In or Register to comment.