Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

Images do not show up in 1.7.8

I just upgraded to 1.7.8 and everything seems to be fine except for one thing. When I click on an image in an entry, the usual dark overlay will appear with at the bottom the option to download the image. That download works fine. The image itself, however, does not appear in the overlay. What might be wrong?


  • Just a follow-up to my previous posting. The media viewer problem I have seems to be browser independent - neither Chrome nor Safari display images in the media viewer. The size of the images does not seem to matter either, nor does it matter whether the image are new pictures uploaded with version 1.7.8 or pictures uploaded with a previous version. In Chrome, I do get a number of warnings about deprecated js code, but no errors. My configuration seems to be fine too. The only three things the CA configuration check page complains about is that my PHP set-up has a memory limit of 90MB instead of the recommended 128MB and that GMagick and ffmpeg are not available, but none of this this has never been an issue in the past. I do not upload any media other than images and image processing seems to go just fine through Imagick. I am not sure what role the memory_limit variable plays or whether I can even change that on my end without asking my provider.


  • I too have the same problem. I have Ubuntu 18 LTS server with github clones for both the Providence 1.7.8 and Pawtucket2. My PHP memory limit is set to 2gb which make no difference. I have tried both Imagemagick and Graphicemagick with no difference. The uploading, download and thumbs all work fine, just no image ever shows up in the viewer. It's like the viewer missed the file name. A little thing but annoying, if anyone finds the fix I'd be grateful.


  • I have the same problem - if I change media_display.conf media overlay from TileView to UniversalViewer or Mirador then image is visible just does not show up in TileViewer

  • You are right! UniversalViewer works fine. Mirador works in the ImageView only -- the scroll and gallery do not display any images either, but I did not test that for more than one image with an entry. This works for me, but TileViewer used to work too. I am not sure which version was the last one for which TileViewer worked, but I used 1.7.6 for a bit without noticing anything out of the ordinary, so I am assuming it worked then. I skipped 1.7.7.

  • I downgraded my 1.7.8 to 1.7.7 and it was the same problem. I'll consider going down to 1.7.6 but I'll have to read over the change log first.

  • What version did you upgrade from?

  • In my case I installed a fresh version of 1.7.8 and I uploaded a jpeg and a pdf file as object media representations. to test. The pdf opens perfectly with Universal Viewer and search for words is possible. In the case of the jpeg with TileViewer set the viewer opens and shows the tool buttons but no image appears. I have tried deleting all media files and then uploading them again but I get the same result. The jpeg appears ok as a random object and also appears ok on the object editor screen. If I change TileViewer to UniversalViewer then the image shows up but of course there are no tool buttons. Hope this helps some.

  • edited June 2019

    Can you try dropping this file in viewers/apps ? (Uncompress it first of course)

  • Hi Seth, This seems to have solved the problem image shows up and most of the tools seem to work ok - not sure about the pan but will try this out later. Many thanks for all your efforts. Eric

  • I appreciate everyone's interest and efforts even if the replacement TilePic.php did not work in my case. The tools show up but still no image. It might be my fault because I'm very new to ColectiveAccess and I'm finding my way around using the bumble around method. My setup is a fresh install of CollectiveAccess 1.7.8 on a Ubuntu Server. The UniversalViewer displays the image and gives users a way to download it if that's what they want. This is all I ask, so I'll not be downgrading to 1.7.6

  • bsims: Is there a URL I can use to see this system running?

  • TileViewer works for me after swapping out the old tilepic view with Seth's new one: The image shows up and the slider works as it is supposed to. Thanks!

  • Seth, everything I've done/doing is local testing/learning, nothing is on line yet. If you have a place to drop it I can zip it up for you OR you can have a copy of my whole 2.7 gig .vmdk if that's better.

  • Either will work. Maybe use DropBox, GoogleDrive or the like to send it?

  • Thanks. I'll take a look.

  • Hi Seth, replacing tilepic.php file worked fine. I assume this solution will be included in upcoming release or develop branch. At the moment though i see no such change has been made in develop branch.

  • Seth, after doing a straight up install on a fresh computer with no virtualization your tilepic.php worked fine. I have no idea why it didn't work on my test install but I'm happy to report it works on Ubuntu server 18.04. Thank you so much for all your work to help us hopefuls.

  • Hi! I have the same issue with a new 1.7.8 installation tried the Titlepic.php replacement but still no image. Any idea what to do?

  • Hi!
    I have solved the issue, but it’s a ugly hack not a permanent solution.
    I had to do some editing of the titlepic.php above.
    I hard coded the $script_path parameter and removed one slash from the $putput line:

    Original line:
    $output = caTilepicGetTileQuickly($script_path."/".$filepath.".tpc", $tile);
    Modified line:
    $output = caTilepicGetTileQuickly($script_path.$filepath.".tpc", $tile);

    Im running on a Windows system and this was what the two parmeters looked like before the if statement in my system:

    $filepath: /test178/enkel/media/collectiveaccess/tilepics/1/1/0/6/58661_ca_object_representations_media_110678_tilepic
    $script_path: D:/xampp/htdocs/test178/enkel

    As you can see the two paths have a double “path” part: “/test178/enkel”
    So I hardcoded the $script_path to “D:/xampp/htdocs“ and with the change aboce to the $output line the title viewer now works.

    Don’t know if its something with my system or if there will need to be a change made to the code in future versions.

    Hope this can help someon oute there!


  • edited October 2019

    Hi! In my case (Pawtucket 1.7.8 on ubuntu 16.04), fixed tilepic.php works fine in providence but output "Invalid file" in pawtucket.

    In pawtucket my "tpc" file output path should be:
    but tilepic.php generates:

    When I debugging tilepic.php $script_path results /var/www/html/providence/pawtucket
    and $filepath results /providence/pawtucket/media/collectiveaccess/tilepics/0/XXXXX_ca_object_representations_media_XX_tilepic.tpc

    hardcoding $script_path as /var/www/html solves the problem for now :(

  • There's a version of tilepic.php in the Github develop branch ( that should work better.

  • Same happened to me. Tried every tilepic.php file in github or wherever, to no avail. Is there some patch already? The murchmurch solution is for windows, and I'm running on Ubuntu.

  • Well, now I get it. Solved, actually a very small thing. I was downloading the tilepic with wget from the server. Oddly, the link did not get the right file, but redirected to some other thing with over 1500 lines. I noticed this looking into the Github link you sent me, so I cut and paste the 134 lines in the page and got my problem solved. Thanks a lot Seth.

Sign In or Register to comment.