Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Getting Fatal Error Messages in both Providence and Pawtucket

I really need help. Not sure when this started or how, have been getting fatal error messages:

In Pawtucket (This has been happening whenever we call the URL. It will take a long time to load and this error message will come up on a white screen instead of loading the actual page)

  • Fatal Error: Maximum execution time of 30 seconds exceeded in /var/www/html/pawtucket/app/helpers/utilityHelpers.php on line 412

In Providence (These shows up usually shortly after the warnings, after we refresh the page)

  • Fatal Error: Out of memory (allocated 2097152) (tried to allocate 65536 bytes) in var/www/html/caadmin/app/lib/ca/IDNumbering/IDNumber.php on line 39
  • Fatal Error: Out of memory (allocated 2097152) (tried to allocate 20480 bytes) in var/www/html/caadmin/vendor/ezyang/htmlpurifier/library/HTMLPurifier/DefinitionCache/Serializer.php on line 73
  • Fatal Error: Out of memory (allocated 10485760) (tried to allocate 20480 bytes) in var/www/html/caadmin/app/models/ca_user_representation_annotations_x_entities.php on line 0

Also in Providence but a warning (appeared in results detail page)

  • Warning: exec(): Unable to fork [/user/bin/ffmpeg>/dev/null 2>&1] in /var/www/html/caadmin/app/helpers on line 156
  • Warning: exec(): Unable to fork [/user/bin/libreoffice --version 2>/dev/null] in /var/www/html/caadmin/app/helpers on line 237

Any help is greatly appreciated. This is beyond us. Never even gone into those folders or lines.

How do I fix this?

Comments

  • Try upping the memory_limit setting in php.ini to something higher. Maybe try 256m and see how that works.

Sign In or Register to comment.