Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Pawtucket object browse by storage location

Hi, I'm trying to add the ability to filter objects by storage location in Pawtucket browse. I've tried copying the working facet from Providence browse.conf to the Pawtucket browse.conf:

    storage_location_facet = {
        type = authority,
        table = ca_storage_locations,
        relationship_table = ca_objects_x_storage_locations,
        restrict_to_types = [],
        restrict_to_relationship_types = [],

        group_mode = hierarchical,

        # Set to non-zero value to display hierarchy on items in this facet
        show_hierarchy = 1,

        # Character(s) to place between elements of the hierarchy
        hierarchical_delimiter =  ⬅ ,

        # Number of items to trim off the top
        remove_first_items = 0,

        # Maximum length of hierarchy to display
        hierarchy_limit = 3,

        # can be ASC or DESC
        hierarchy_order  = DESC,

        label_singular = _("storage location"),
        label_plural = _("storage locations")
    },

However, this facet doesn't appear in my filters. I've confirmed that I have objects with related storage locations. Is there a configuration change I need to make in order to make storage location visible on the Pawtucket side?

Thanks,
Elizabeth

Comments

  • Hi Elizabeth, Have you made sure your storage location records and the objects linked to them are accessible to the public? This would account for the facet appearing in the Providence browse, but not Pawtucket.

  • Hi Maria, thanks for your response. I've made the storage location type, root node of storage_location_types, and the storage location record accessible to public. The object was accessible to public already. I'm still not seeing a filter for it in browse. Is there a setting I'm missing?

  • Do you have browse caching turned off by setting cache_timeout = 0 in browse.conf?

  • Oops, I got it working now. I guess by default storage location access is not in the standard locations editor UI in Providence. I had to add the access field to the editor UI first in order to change the storage location record to accessible to public. Thanks again for your help.

Sign In or Register to comment.