Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Clicked on images on front-end are mostly blurry

Hi Support, sorry to bother you. I have uploaded a bunch of images perfectly to CA. In the back-end or downloaded, the images are crystal clear. In the initial record public view, they are also fine.

However, when you click on them to view the 'blown up' image, it looks like is starts to render the image properly, and then stops. Screenshot attached. I searched around for an answer, but couldn't find one, sorry. Please help? Thank you!!

Comments

  • Can anybody help with this please? We're really stuck and can't figure out what the problem is?

  • Hi all,

    We're experiencing the same issue on the frontend/backend with CA version 1.7.6.

    Tilepic loads and (possibly after the 6th tile?) stops. A little bit more detail: this issue is only happening in Chrome, not Firefox or Safari. Is it possible that Chrome is accessing a newer version of jquery?

    Thank you for your assistance with this.

  • Post a link to this actually happening please?

  • Only when the image is expanded: https://digitalarchives.library.newschool.edu/index.php/Detail/objects/KA0023_kOSxx2_f06_01

    This is only for images, not pdfs or a/v.

  • They load fine in browsers other than Chrome. Apparently with Chrome version 76 which recently was released (and maybe as early as v75) there is a change relating to lazy loading of images that breaks the zooming viewer. There's a fix for this in GitHub (https://github.com/collectiveaccess/providence/commit/8a51fcc7115f39274fa2f00c9c2417f8cd589dd1) You can patch this by replacing the modified file in your install with the one in GitHub, or wait for the next release in the next few weeks.

  • That worked. Thank you!

  • Thanks Seth! I passed a troubled night thinking about what could have appened...

  • edited August 2019

    I just noted that now the tile loading is a bit slower than before... Any hint to make it faster?

  • Hi Seth, Thanks very much for your assistance. I can confirm the problem only occurs in Chrome. I downloaded the file from Github, uploaded it to providence/assets/jquery/jquery-tileviewer (as you can see from the attached image), cleared cache, restarted Chrome and the problem persists (https://archive.kaldorartprojects.org.au/index.php/Detail/objects/189) - am I doing something wrong? Apologies if so.

    If there's a new CA release, how do I implement that into my existing site? Do I download the zip and copy the files manually? Apologies, I couldn't find instructions. Thank you.

  • I also needed to make the changes to the similar file in my Pawtucket installation, found at the same path relative to the Pawtucket home directory.

  • Oh dear, this has now gone from bad to worse - I just tried to do the above, and now the site is broken with an error 'Errors occurred when trying to access /index.php/Detail//174:
    Action is not defined' when you click on any image - https://archive.kaldorartprojects.org.au/ I really need some help with this. Does anybody know who I can contact please? Now I'm really worried.

  • edited September 2019

    Did you flush tmp folder? Altough it seems something else...
    Double check the mods you made. It seems it is missing something before the ID

  • I tried this fix as well, cleared the cache and restarted the server and it hasn't seemed to make a difference...

  • Hi! The fix does not seem to work in pawtucket2. The immages are still blurry when displayed (1.7.8) Any ide where to start troubleshooting this?

  • Some more of the image is loading when i use the mousewheel to scroll zoom the miage.. but main part of the immage is still blurry.

  • edited October 2019

    Disregard my two earlier posts. It works now in pawtucket2 after applying the fix, clearing the application TMP folder AND clearing the Chrome cashe and refreshing the page (ctrl + f5).

    The loading is slow as other people have noticed and looking at the network trace the tiles are read in sequence and not in parallel. Is this possible to change in some way? Or is it my Web server that needs to be uppgraded to send the tiles faster?

  • The viewer is supposed to load tiles in parallel.

  • In my browser it doesn't not look like that is happening:

  • edited April 11

    Got exactly the same problem (after the tilepic.php update, which I tested on a lower-resolution image). Tried the fix indicated, didn't work. I use Firefox and Vivaldi. It seems to be about high-resolution images. The tiled image loads very quickly, just a large part of it is blurred.![]

  • Tried everything: clearing the app/tmp and the cache, nothing works. Using Firefox

  • Well, this kinda sucks. I tried the fix by fixing the lines that changed, no go for either Firefox 75.0 and Chrome 80...

    This one of the best features.

    I have verified that is is "lazy loading". I know the last working version of Firefox that I had was 72.0.2.

    I am running ver 1.6.4 and upgrading is going to hurt, Not just CA, but the whole OS too. CentOS 7, I could never get CA and PHP 7 to play nice.

    To the CA team, I get it. It's is not your fault they deprecated that function, most likely a security thing.

  • Maybe just try updating assets/jquery/jquery-tileviewer/jquery.tileviewer.js with the one in GitHub? https://github.com/collectiveaccess/providence/blob/develop/assets/jquery/jquery-tileviewer/jquery.tileviewer.js

  • I tried that and it still does not seem to work, did not break anything either which is good.

    Seth, any other ideas? I tried both Firefox 75 and Chrome 81.

  • Flush your browser cache.

  • Yahoo, we are a farther. Chrome now works, Firefox, not so much... Anyone get this working on the new versions of Firefox?

    Thanks Seth

  • edited April 21

    Just a quick finding with Firefox. Once I turn Lazy Loading "off" in Firefox, all works again, and really speeds things up.

    Not sure what to do about this.

  • Not working for me... Firefox gets stuck loading tiles.

  • Its a setting in Firefox. It will only work for you, not your visitors.

Sign In or Register to comment.