Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Pawtucket media configuration

edited August 21 in Pawtucket

Hi,
I configured providence in my /providence directory, adding few objects in its DB.

Then I tryed installed pawtucket in the /pawtucket2 directory.
Copying the /providence/media directory into the /pawtucket2/media directory, the website worked properly; see:
abruzzocultura.com/pawtucket2/

To avoid duplicating media files, I Installed pawtucket in a /pawtucket directory and I added the following configuration to the /public_html/abruzzocultura.com/pawtucket/app/conf/global.conf file according to the installation procedure in https://docs.collectiveaccess.org/wiki/Installing_Pawtucket

site_protocol = https
site_hostname = abruzzocultura.com
ca_url_root = /providence
ca_media_url_root = /providence/media/< app_name>
ca_media_root_dir = < ca_base_dir>/media/< app_name>

The result is the following, with a wrong page layout:
abruzzocultura.com/pawtucket/

Same result installing pawtucket in the providence subdirectory /providence/pawtucket/ with the same configuration in the /public_html/abruzzocultura.com/providence/pawtucket/app/conf/global.conf file; see:
abruzzocultura.com/providence/pawtucket/

Could you please help me to understand how to fix the last two configurations?
Thanks, Pietro

Sign In or Register to comment.