Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

New Items not added to indices automatically

Sometime a few months back, i noticed that creating any new item or editing any item, it is not added to the indices automatically. As a workaround, I used crontab to manually reindex several times a day. This is no longer sufficient. Any hints about where to look for the problem?

Comments

  • Do you have out of process indexing enabled? It is by default. Look in app.conf for disable_out_of_process_search_indexing. If it's set to zero then it's enabled.

    Out of process indexing applies search indexing in a separate process to improve responsiveness. The indexing process is triggered by a socket connection on the server. In some networking setups the socket connection can fail and a backlog of indexing tasks will grow. There are settings in app.conf just below disable_out_of_process_search_indexing that may be of help. You can also set disable_out_of_process_search_indexing to a non zero value to force indexing to happen in-request. This may slow things down a bit, but often it's fine.

    You can force the out of process indexing to trigger on the command line using the caUtils process-indexing-queue command. If you can't get the automatic triggering to function as it should, a work-around would be to run caUtils process-indexing-queue in a cron script every X minutes.

    seth

  • Bingo!!! That's the issue. Now I know what to talk about with my server manager. Thank you so much. Can you tell me more detail about the socket connection that might help him troubleshoot?

  • It's trying to connect on the server via same host name used the by request on either port 80 (if the original request was via http) or port 443 (if the original request was via https). You can override these defaults in app.conf.

    One common problem: the hostname you access the machine with only resolves externally and doesn't resolve on the server itself. So when you go to ca.whatever.com it works fine, but when a process on the machine itself tries to hit that url ca.whatever.com doesn't resolve and the connection fails.

    seth

Sign In or Register to comment.