Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

relationships link produces fatal error

I have a fresh installation of providence. It works fine, but when I try to create relationships for an object, I get this error message:

Fatal error: Uncaught Error: Class 'ca_entities' not found in /Users/Shared/Sites/providence/app/lib/BundlableLabelableBaseModelWithAttributes.php:3007 Stack trace: #0 /Users/Shared/Sites/providence/app/lib/BundlableLabelableBaseModelWithAttributes.php(1599): BundlableLabelableBaseModelWithAttributes->getRelatedListHTMLFormBundle(Object(RequestHTTP), 'ca_entities_rel...', 'ObjectEditorFor...', 'P165', Array, Array) #1 /Users/Shared/Sites/providence/app/lib/BundlableLabelableBaseModelWithAttributes.php(2529): BundlableLabelableBaseModelWithAttributes->getBundleFormHTML('ca_entities_rel...', 'P165', Array, Array, NULL) #2 /Users/Shared/Sites/providence/themes/default/views/editor/objects/screen_html.php(59): BundlableLabelableBaseModelWithAttributes->getBundleFormHTMLForScreen('Screen49', Array, Array) #3 /Users/Shared/Sites/providence/app/lib/View.php(329): require('/Users/Shared/S...') #4 /Users/Shared/Sites/providence/app/lib/View.php(297): View->_render('/Users/Shared/S...') #5 /Users/Shared/Sites/providence/app/lib/Con in /Users/Shared/Sites/providence/app/lib/BundlableLabelableBaseModelWithAttributes.php on line 3007

Has anybody got the same message? How did you solve the problem?

Comments

  • What profile are you using? I assume you're using the current release?

  • yes, current release (from github). I installed the test profile. Should I try out out other profiles?

  • Yes please give another profile a try and let me know if the same problem is apparent. Thanks.

  • thank you, Seth. Problem solved with profil dublincore2014.

Sign In or Register to comment.