Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

error when updating

I'm trying to update an installation from 1.4 to 1.7.8. But i've encountered the following error.

ERROR --> DatabaseException: Error on rename of './design_update/ca_batch_log_items' to './design_update/#sql2-c5f1-fe49' (errno: 152)

Google suggest it's a problem with foreign key restraints but I can't find any contraints in ca_batch_log_items. I also get the same error after running SET FOREIGN_KEY_CHECKS = 0 in mysql.

I'm trying this update on a clone of the original database.

Comments

  • Nevermind. I figured it out. If someone else has a similar issue the problem for me was that there wasn't a foreign key constraint set. The setting hadn't been set correctly when cloning the database.

  • I also faced almost the same problem, just it comes with iTunes Error 9006. It comes me like a nightmare, I can't fix it but after some discussion and tried all the possible ways I find How to Resolve Error 9006 In iTunes.

Sign In or Register to comment.