Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Images not displaying in Pawtucket

I have installed Providence and Pawtucket 2 on the same Ubuntu 18.04 server.

I can see uploaded jpg images in Providence, but not in Pawtucket. The site is http://niserver.ddns.net/pawtucket
I have tried both using a symlink from providence/media to pawtucket/media, and editing the global.conf file to use /var/www/html/providence/media, but neither option has fixed the problem.

Link:
From directory /var/www/html/pawtucket
lrwxrwxrwx 1 www-data www-data 30 Dec 20 07:07 media -> /var/www/html/providence/media

Php -i output (clipped):
Configuration

gd

GD Support => enabled
GD headers Version => 2.2.5
GD library Version => 2.2.5
FreeType Support => enabled
FreeType Linkage => with freetype
FreeType Version => 2.8.1
GIF Read Support => enabled
GIF Create Support => enabled
JPEG Support => enabled
libJPEG Version => 8
PNG Support => enabled
libPNG Version => 1.6.34
WBMP Support => enabled
XPM Support => enabled
libXpm Version => 30411
XBM Support => enabled
WebP Support => enabled

How can I fix this?

Comments

  • Make sure you've set access for all media items to "accessible to public". Setting access for the object itself will only show the record. Media have their own access values.

  • Both the Collection and the objects are all set to "accessible to the public" I tried changing it to not accessible and saving, then back to accessible, but still have the same problem.

  • Are the media representations themselves set to accessible to public? It looks like they're not.

  • edited December 2019

    I have changed AP000001 to accessible in the media representation, and now I get a different "Image not found" icon on the Pawtucket display.

  • Update: I added some new items (PDF's) and the thumbnails for these are not showing either. However the media is available when you select an object. I hope I am using the correct terms - I am not an archivist by profession!

  • Is there any way for me to see this site? The broken image implies you have the symlink set up incorrectly.

  • edited December 2019

    Here is the directory list:

    nirvine@niserver:/var/www/html/pawtucket$ ls -l
    total 292
    drwxr-xr-x 14 www-data www-data 4096 Dec 18 20:01 app
    drwxr-xr-x 19 www-data www-data 4096 Dec 18 20:01 assets
    -rw-r--r-- 1 www-data www-data 729 Dec 18 20:01 composer.json
    -rw-r--r-- 1 www-data www-data 1076 Dec 18 20:01 composer.json-okta
    -rw-r--r-- 1 www-data www-data 168028 Dec 18 20:01 composer.lock
    -rwxr-xr-x 1 www-data www-data 5424 Dec 18 20:01 index.php
    -rwxr-xr-x 1 www-data www-data 35146 Dec 18 20:01 License.txt
    lrwxrwxrwx 1 www-data www-data 30 Dec 20 07:07 media -> /var/www/html/providence/media
    -rw-r--r-- 1 www-data www-data 6363 Dec 18 20:01 README.md
    -rw-r--r-- 1 www-data www-data 274 Dec 18 20:01 robots.txt
    -rw-r--r-- 1 www-data www-data 1931 Dec 18 20:01 service.php
    -rw-r--r-- 1 www-data www-data 11851 Dec 18 23:42 setup.php
    -rw-r--r-- 1 www-data www-data 11902 Dec 18 20:01 setup.php-dist
    drwxr-xr-x 6 www-data www-data 4096 Dec 18 20:01 support
    -rwxr-xr-x 1 www-data www-data 1081 Dec 18 20:01 THANKS.txt
    drwxr-xr-x 4 www-data www-data 4096 Dec 18 20:01 themes
    drwxr-xr-x 36 www-data www-data 4096 Dec 18 20:01 vendor
    drwxr-xr-x 3 www-data www-data 4096 Dec 18 20:01 viewers
    -rwxr-xr-x 1 www-data www-data 648 Dec 18 20:01 Warranty.txt

    Can I PM you? I appreciate the help.
    When you "see the site" I am assuming you mean the server.

  • You can email me at seth@collectiveaccess.org

  • Send me your Pawtucket setup.php file please. From the looks of those image urls you have the path entered incorrectly.

  • I have deleted Pawtucket and reinstalled, and it is working well now. Thanks for the help.

Sign In or Register to comment.