Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Zend Locale error when upgrading or installing Providence

I have tried to upgrade my installation of Providence from 1.7.5 to 1.7.8 as well as a fresh install of 1.7.8. I get the following error:

Fatal error: Cannot declare class Zend_Locale, because the name is already in use in /path/to/providence/app/lib/Zend/Locale.php on line 30

CollectiveAccess was working in 1.7.5 without any errors. I am using PHP version 7.2.24 in Ubuntu 18.04. The problem seems similar to this error: https://stackoverflow.com/questions/52301800/fatal-error-cannot-declare-class-error-because-the-name-is-already-in-use

Comments

  • edited January 21

    Hello,

    we are currently confused as well. We've tried to upgrade Providence from 1.7.1 to 1.7.8 and we got the same error:
    Cannot declare class Zend_Locale, because the name is already in use in <collectiveaccess>/app/lib/Zend/Locale.php

    Tested with PHP 5.6, 7.2 on Debian Buster

    Any suggestions?

  • I experienced this same problem on Fedora 32 as the embedded Zend was clashing with the system installed Zend. After a little investigation I found the setup.php had been significantly altered and the new PHP include path that is set by the new setup.php-dist template (and post-setup.php script) fixes this problem. Therefore transferring settings from the old setup.php to a new one, as copied from setup.php-dist, fixed the issue.

Sign In or Register to comment.