Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

Cannot change Base Map

In the documentation, it says that I can change the base map from Google to OpenStreetMap.

I would really like to do this, as OSM has much more information in my region. However the option is not available on the Preferences tab:

Help please? Even if it is just to tell me that I need to provide more information, or that the question cannot be answered.


  • That documentation is for the old OpenLayers based mapping code – it's out of date I'm afraid.

    Current CA versions use Leaflet to generate maps. There are a number of app.conf options to control how Leaflet works. The one you want, I think, is leaflet_base_layer.

    See for previews of various base maps

  • Yes, that is probably the setting I need.
    Could you please tell me the syntax for the app.conf entry?

  • It's a url like this:


    That site has various links in this format you can use.

  • Changed - many thanks.

  • edited June 19

    Hi Nirvine,

    Could you explain what exactly you wrote in the app.conf file, to change the default map for OSM?

    Thank you.

  • edited June 20

    Change the relevant section in the file (in Pawtcukect installation directory) themes/default/conf/app.conf

    leaflet_base_layer = {OpenStreetMap_Mapnik = L.tileLayer('https://{s}{z}/{x}/{y}.png', {
    maxZoom: 19,
    attribution: '© OpenStreetMap contributors'}

    And in app/conf/app.conf change the leaflet base layer parameter to:

    leaflet_base_layer = https://{s}{z}/{x}/{y}.png

  • Thank you Nirvine.

Sign In or Register to comment.