Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

entitySplitter and organization names

We're using the entitySplitter refinery to load both personal names and organization names into our entity table. It works great for personal names, parsing them into first, middle, and last name fields. For organization names, it often drops part of the name. I thought I had figured out the solution by adding "{"doNotParse": "1"}" to the parameters, but that breaks the parsing of personal names (the entire field loads into last name). The documentation notes that "This setting will force the import to migrate an organization's name as is when using the "entity_class" = ORG setting." Our incoming data has an entityType of "org" but I can't find any other information about this mysterious "entity_class". Has anyone else used this and might have any suggestions for us? Thanks!

Comments

  • Entity class is a setting an entity type. To set it go to Lists & Vocabularies (in the Manage menu), select the Entity types list in the hierarchy browser and open up the "organization" type (or whatever it's set to in your install). You should see a control on the form to set the entity type (screen shot below).

    If the setting is correct and it's still skipping parsing in all cases there may be something else going on.

Sign In or Register to comment.