Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Fatal error: Uncaught DatabaseException

Hello! I'm new to CollectiveAccess and I'm trying to install Providence for the small museum I intern for. I'm using the latest versions of Firefox and Windows 10, as well as Wampserver 3.2.0. It was going smoothly but I've run into a bit of an issue with the web installer. When I try accessing the installer (http://localhost/providence-master/install/) I get the following error:

_Fatal error: Uncaught DatabaseException: Access denied for user 'elmpuser'@'localhost' (using password: YES) in C:\wamp\www\providence-master\app\lib\Db\mysqli.php on line 139

DatabaseException: Access denied for user 'elmpuser'@'localhost' (using password: YES) in C:\wamp\www\providence-master\app\lib\Db\mysqli.php on line 139_

I've tried tweaking the code a bit but I'm scared to make any mistakes.

Comments

  • I'd check your MySQL login information set in setup.php. The error indicates that the information is incorrect – either the user name or password is wrong, or the login was never set up in the first place.

Sign In or Register to comment.