Applying Date Format

I'd like to configure my CA installation to display dates in format DD/MM/YYYY using locale pt_PT.

I came across this and followed the instructions there.

I edited file /app/lib/Parsers/TimeExpressionParser/pt_PT.lang and changed value monthComesFirstInDelimitedDate to 0.
However, setting UI locale to portuguese (MANAGE > My preferences > GENERAL > User Inteface locale) does not change the date presentation format (it keeps being displayed as MM/DD/YYYY)

I tested clearing temporary files in /app/tmp and performing maintenance operations (rebuild search indexes, reloard sort values, rebuild hierarquical values) but DateRange values keep being displayed as MM/DD/YYYY

I also tested setting UI locale to English (Australia) and in this case the Date format is applied correctly (it's displayed as DD/MM/YYYY).

What must I do to make the pt_PT locale behave the same as the en_AU locale?

Thanks in advance

Comments

  • I forgot to mention that I am using Providence 1.7.8

  • That should work... what is your dateFormat setting set to in datetime.conf?

  • Hi Seth! Thanks for the reply.

    dateFormat is set to text in /app/conf/datetime.conf:


    Output options for date/times

    Format to use for dates; valid values are (text|delimited|iso8601|original) [default is text]# "original" is the date as entered by the user; other values will normalize all date/time input
    to the selected standard format

    dateFormat = text


    Should it be different?

    Also, since there is an iso601 option for this field, is there also an option to use European Delimited (ex. 03/07/2012) (like the Date picker date format option that can be set for DateRange in the metadata elements)?

  • Hi, I finally figured out what I was doing wrong and was able to make the configurations I needed.
    Regarding the date format, setting monthComesFirstInDelimitedDate to 0 in file /app/lib/Parsers/TimeExpressionParser/pt_PT.lang was enough to make it be displayed as DD/MM/YYYY

    I made some other changes to the pt_PT.lang file and made a contribution to branch master-fix

Sign In or Register to comment.