Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Images with special charakter will not be displayed

I made a batch upload of images, which are directly linked with the idno of an entry. It worked perfectly for files without special characters. But for every image with special characters (i.e. Değirmendere) the upload and link works, but the image is only shown as binary file:

The download of the orignal image works fine, but when I try to download Small/Medium/Large then I only get a binary file. And the images also doesn't work in pawtucket2.

I tried to change the encoding to ISO-8859-9, but didn't work either.

If I upload the file manually, it also works!

Comments

  • If you remove the accented characters does batch upload of them work?

  • edited May 13

    yes, it works! So I have to change every image name to the standard characters. Ok thank you very much!

  • What media processing plugins are you using? Can you post a screen shot of your Configuration Check screen?

  • Are you running on Linux, Mac or Windows?

  • Linux, Debian 10

  • You're running the command-line GraphicsMagick plugin, which means it's exec'ing a command-line process (pretty much as if you had typed it yourself) for each uploaded image. It's possible the characters are causing that to fail for GraphicsMagick, either because we're not escaping those characters properly or some other issue. I'll try to reproduce this on my machines.

  • So it turns out the culprit is the PHP escapeshellarg() function, which will in some cases on some platforms strip all non-ascii characters from text passed to it. The command-line exec()-based plugins all use escapeshellarg().

    The fix is to explicitly declare a Unicode locale, which we're now doing during preload. The JIRA ticket for this is https://collectiveaccess.atlassian.net/browse/PROV-2876. The commit is https://github.com/collectiveaccess/providence/commit/e80911fd6c0a03476dd5d0e240c5a3e7e6180faa

  • edited May 20

    Sorry for the late answer, I could work on providence until now. Bit thanks to you seth! It works!
    But I think you have a little typo. I changed:
    setlocale(LC_CTYPE, $g_ui_locale ? "{$g_ui_locale}.UTF-8" : "en_US.UTF-9");
    to
    setlocale(LC_CTYPE, $g_ui_locale ? "{$g_ui_locale}.UTF-8" : "en_US.UTF-8");

    But many thanks!!!! Now I have to get rid of all the binary files...

Sign In or Register to comment.