Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

How to Disable Tilepic?

Have a client's site that is starting to take up quite a lot of storage space, and they've asked for suggestions on how to trim things down.

It seems the major contributor to the size of our CollectiveAccess install is the tilepics folder. I think that we could probably safely disable Tilepics on this particular installation - I don't think our users would miss this functionality.

What is the proper method for disabling Tilepic? I have tried looking through the .conf files, searched here and in the docs and I can't seem to find anything specific about this.

Thanks!

Comments

  • Hi Karyl,

    Keep in mind I'm not an expert and have just been dealing with something similar lately but what your probably looking for is under the media_processing.conf this is the configuration file that tells CA what to generate for every upload of media inside of it you'll find a number of different "rules" one of which will be the Tilepic. That said, you'll also have to remember to go through media_display.conf and change it appropriately so that it doesn't try to go looking for a tilepic that isn't there. Unfortunately this only really fixes it for future uploads however I believe in the caUtils there is a utility to reprocess media which I know works for adding rules to media_processing.conf I've never tried it after removing one but... maybe it would work. Again I haven't been in your particular case before but maybe this will help give some initial direction.

    Hope that helps.

  • Hi Alan,

    Thanks for your reply- I'll have a look at those and see if I can make it work. Cheers!

  • edited June 24

    Thanks to your clues Alan, I was able to sort this out. I figured I'd reply here again with details on my solution, in case it might serve anyone else in the future.

    NOTE: probably a good idea to take a backup of everything before messing around, can't hurt right?

    File: /app/media_processing.conf

    • All references to tilepic have been commented out (not deleted).
    • All instances of MEDIA_VIEW_DEFAULT_VERSION where it was set to "tilepic" have been replaced with either "large" or "original" on the next line, depending on what other versions were available for that specific media type.
    • What this does: disables creation of NEW tilepic images, but does not remove existing generated tilepics.

    File: /app/media_display.conf

    • All references to tilepic have been commented out (not deleted).
    • All instances of "display_version" where it was set to "tilepic" have been replaced with "original".
    • What this does: prevents CollectiveAccess from looking for tilepic images, since we're not generating them any longer.

    Files: /media/collectiveaccess/tilepic

    • After the above two files were updated, I moved this folder up to the root installation folder, and did a bunch of testing within CollectiveAccess to make sure everything was working as expected.
    • After I had done enough testing to feel confident that things were working properly, I deleted the "tilepic" folder.
    • Since all the other media files were processed correctly and didn't change, I opted NOT to run "/support/bin/caUtils reprocess-media".
Sign In or Register to comment.