Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

bug, Fatal error inside app/lib/ResultContext.php

Hello.
We found an issue inside the object editor when we click on the "paperclip" button, as you can see from the screenshot.
The CA version is 1.7.8.

The popup window shows a blank page and inside the logs we can find:

PHP Fatal error:  Uncaught Error:** Call to a member function getParameter() on null** in /data/www/html/cola/app/lib/ResultContext.php:617
Stack trace:
#0 /data/www/html/cola/app/lib/BaseInterstitialController.php(127): ResultContext->getParameter('ca_objects_x_en...')
#1 /data/www/html/cola/app/lib/Controller/RequestDispatcher.php(273): BaseInterstitialController->Form(NULL)
#2 /data/www/html/cola/app/lib/Controller/AppController.php(113): RequestDispatcher->dispatch(Array)
#3 /data/www/html/cola/index.php(128): AppController->dispatch(true)
#4 {main}

If we try a var_dump of $_REQUEST it return an empty array and $this->opo_request is null.
We see that the function getParameter of ResultContext has the parameter $pb_dont_fetch_from_request=false. If we set it to true it works, so we think that the issue is that in this case the function should be call passing $pb_dont_fetch_from_request = true, or maybe there is an issue somewhere else with the request.

Can you help us?

Sign In or Register to comment.