Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Troubles with login after installation

edited July 26 in Installation

Hi, I'm a first time user of collective access because I'm doing an investigation for class. After a lot of trouble, I've finished the installation of Providence but when I try to login it says Login Invalid. I'm not sure if this means anything but I'm using XAMPP (localhost:8080)

This is the error:

Warning: fsockopen(): unable to connect to tcp://localhost:8080:8080 (Connection refused) in /opt/lampp/htdocs/providence/app/lib/Controller/Request/RequestHTTP.php on line 660

Could anyone help me with what to do with this? I can't find any info and I've checked the setup and the username and password are 100% right
I'm using a Mac as well

Comments

  • You can resolve the fsockopen error by setting disable_out_of_process_search_indexing = 1 in your app.conf file. The error is due a configuration error in your install due to the non-standard port.

    With regards to the login failing, the logins provided by the installer when it finished should work. If they don't I would guess there was an error with the installer, and you should look for an on-screen message to that effect.

  • I changed to 1 in app.conf and it worked! It no longer shows the warning. However, I keep trying to login after doing this and it says "Login Was Invalid" but offers me no message telling me what the error is now. I tried changing my password (and then changing again in setup.php) but it keeps showing the same thing. I've seen some forums saying it sometimes takes time so I'm not sure if I should give it a day and hope for the best or if there's anything else I can do.

  • Did the installer display login information to you upon completion?

  • Yes, it did, then everytime I try to enter the page it offers me to login

  • What does the login info look like?

Sign In or Register to comment.