Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

New install getting stuck on "Installing database table for list items".

Ubuntu Server v20.04 running PHP v7.4, mySQL v8.0, Providence v1.7.8 with imagick and gmagick installed.
I followed the "Installing_Providence" steps and everything seems like it should work, but it doesn’t. Providence is installed to /var/www/html/providence. /etc/php/7.4/cli/php.ini was edited to allow large files and to set display_errors = on.
I configured a new mySQL database called ‘collaccdb’, created a new user called ‘causer’, gave the user permissions, and verified that the user can access the database. Edited setup.php with database and user info.
When I run the Providence installer, it starts and then gets stuck at "Installing database table for list items". It never progresses beyond this point.
If I go to /providence, it says "Issues with your system configuration have been detected" and below "It looks like you have not installed your database yet. Check your configuration or run the installer". If I try to run the installer, it tells me that the database tables already exist.

If I log into mySQL as 'causer' I can see the database, and several tables exist inside it:

mysql> show databases;
+--------------------+
| Database |
+--------------------+
| collaccdb |
| information_schema |
+--------------------+
2 rows in set (0.01 sec)

mysql> use collaccdb;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> show tables;
+-------------------------+
| Tables_in_collaccdb |
+-------------------------+
| ca_application_vars |
| ca_change_log |
| ca_change_log_snapshots |
| ca_change_log_subjects |
| ca_eventlog |
| ca_list_labels |
| ca_lists |
| ca_locales |
+-------------------------+
8 rows in set (0.00 sec)

I've gone through this several times, deleting the database, recreating it, making sure it's accessible, and running the installer. I've tried using three different profiles (DACS, DBUCORE, etc). Behavior is always the same.

I seem to be stuck in a catch 22. The database won't finish creating, so the installer thinks it needs to be run, but trying to run it complains that the database already exists. PHP isn't throwing any errors that I can see, and mySQL seems to be working correctly.

I can't seem to find any logs for the install process to investigate. Am I overlooking something obvious?

Comments

  • The current release doesn't support MySQL 8. Try using the develop branch in GitHub.

  • Thanks, I'll look into either using the development branch or replacing the version of mySQL that I have installed, and will report back with the results.

  • Removed mySQL version 8 and replaced with 5.7, then setup the database and user from scratch. That fixed the issue. Much thanks for the help. I didn't even really notice that v8 was installed, but that's the default for Ubuntu 20.

Sign In or Register to comment.