Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Configuration error after moving to new server

Hello helpful folks!

I needed to move a full CA installation from a private server onto a hosted site. So I copied all of the files over from the old installation. And I exported the whole mysql database and imported it onto the hosted mysql database. But I get an "Issues with your system configuration have been detected" and "looks like you have not installed your database yet." I had already gone through and changed everything in the setup.php file to point to the right paths and right database, etc., and when I tried just running an install to see what would happen, it gave me the error that maybe I had already installed CA. What I'm wondering is if the problem is that I had to change the database name for the new install (corrected this in setup.php, too). Or maybe it's a completely different issue? I'm at a loss.

Any help would be appreciated! Thank you!

Comments

  • Make sure you've configured the correct database in setup.php. If it's correct, then make sure the database dump file you used loaded fully. You can do this by logging into mysql, switching to the database and running SHOW TABLES. There should be 200+ tables, the last of which is ca_watch_list.

  • So it turns out the big problem was that rather than loading in a database dump, I loaded in a database export in sql format. Once I loaded in an actual dump, it started working perfectly.

Sign In or Register to comment.