Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Installer: Stuck/ended at "Processing search forms"

I've successfully set up an instance with code from git branch "develop". Yay! :sweat_smile:
However, installing my profile XML (which worked flawlessly in v1.7.8) does not end with a success message (as usual), but froze (or ended?) saying "Processing search forms".

When I manually go to the providence page, I can login and use the instance without any visible issues.
It does not feel right though that it doesn't end cleanly...

In order to avoid profile-XML-dialects between versions, I have exported this profile again in v1.7.9(develop) and re-ran the install:
but same behavior :cry:

I don't find any logfiles or anything where I could check what went wrong (app/log is empty).

Grateful for any hints! :smile:
Thank you very much in advance.

Comments

  • btw:
    Before that I have installed my XML profile in v1.7.8(release) - no errors - then switched to branch origin/develop - then had CA upgrade the database: No errors.

    I've tried exporting and re-installing that XML: Same issue.

    Maybe interesting though:

    I've noticed that the first (unclean?) export only had one "searchForms" present in the profile XML (with bundlePlacements node empty):

    • ca_objects_adv_search

    Whereas this export also had the following searchForms present (including bundlePlacement information):

    • ca_entities_adv_search
    • ca_places_adv_search
    • ca_occurrences_adv_search
    • ca_collections_adv_search
    • ca_storage_locations_adv_search
    • ca_loans_adv_search
  • Try removing those forms from your profile

  • Unfortunately, no success:
    I've tried with a completely empty <searchForms/> node in the XML: Same behavior.

  • Shall I provide you with the profile XML?

  • Update: I've now removed the searchForms in the XML again, but this time the XML that was generated without the DB update: That worked.

    The only real difference I see between these 2 XMLs is the strange case of old-vs-new bundle names, see:
    https://collectiveaccess.org/support/index.php?p=/discussion/300555/old-bundle-naming-v1-7-8-in-newly-exported-profile-xml-v1-7-9#latest

Sign In or Register to comment.