Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Recent "git pull" deletes all Zend libraries

edited October 15 in Troubleshooting

In September, I've checked out the "develop" branch of CA.
In a git-checkout copy where I have not made any changes, "git pull" removes literally hundreds of files in my working copy.
Most prominent one: app/lib/Zend (and many other subfolders in app/lib).

I've tried this with 2 different copies, I have checked out separately back in September: Same situation.
So I thought this is on purpose.

When I try to access the providence installation with that code, I get the following error:

Fatal error: Uncaught Error: Class 'Zend_Search_Lucene_FSM' not found in /var/www/html/ca/providence/app/lib/Search/Common/Parsers/LuceneSyntaxLexer.php:4 Stack trace: #0 /var/www/html/ca/providence/app/lib/Search/Common/Parsers/LuceneSyntaxParser.php(5): require_once() #1 /var/www/html/ca/providence/app/helpers/searchHelpers.php(36): require_once('/var/www/html/c...') #2 /var/www/html/ca/providence/app/lib/BundlableLabelableBaseModelWithAttributes.php(46): require_once('/var/www/html/c...') #3 /var/www/html/ca/providence/app/models/ca_lists.php(37): require_once('/var/www/html/c...') #4 /var/www/html/ca/providence/app/lib/BaseModel.php(12483): require_once('/var/www/html/c...') #5 /var/www/html/ca/providence/app/helpers/preload.php(63): require_once('/var/www/html/c...') #6 /var/www/html/ca/providence/app/helpers/post-setup.php(308): require_once('/var/www/html/c...') #7 /var/www/html/ca/providence/setup.php(221): require('/var/www/html/c...') #8 /var/www/html/ca/providence/index.php(37): require('/var/www/html/c...') #9 in /var/www/html/ca/providence/app/lib/Search/Common/Parsers/LuceneSyntaxLexer.php on line 4

I honestly have no clue what is happening here.
Does anyone have an idea what's causing this?

Thank you very much in advance! :smile:

Comments

  • Please run composer. We've shifted to a packaged version of Zend.

  • That did the trick! :grin:

    Thank you so much. I was pulling my hair for days now, going crazy why I see "delete" lines flooding over my screen when trying to pull or merge anything from upstream.

Sign In or Register to comment.