Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

stuck on installation step 5 - URL installation server - single machine, no network

Hello!

I'm trying to install Providence locally in my laptop, to check it out (linux opensuse 15.2)
starting from zero knowledge about web-based applications.

I managed to perform step 1-4 from the installation manual
the downloaded files are located here: /opt/collectiveaccess/providence/

Now I have no clue how to proceed with the web-based installer in step 5
Maybe its a very basic question for this forum. Hope you can help be out anyways
Thanks!

Comments

  • You'll need a running web server and a mysql install. Do you have both installed and running?

  • yes, I installed web server Apache 2.4 and mysql

  • As you are working with a local machine, perhaps try the url: localhost/providence/install or localhost/collectiveaccess/providence/install depending on how your server is set up.

  • Thank you seth and sjenson.
    I got one step further.
    I have mysql and apache running and managed do access the url: localhost/collectiveaccess/providence/install

    then in firefox I get an error 403 that there is no index document.
    to find the error I created an empty html document in the directory and tried again. I can open it.

    Then I tried to open de index.php file in the terminal, to see if it works:
    php -f /srv/www/htdocs/collectiveaccess/providence/install/index.php

    It works but I get the message:
    "
    You don't have a setup.php file present in the web root directory of your CollectiveAccess set up. Please copy setup.php-dist to setup.php, customize it and re-run the installer.chrisfo@linux:~> php -f /srv/www/htdocs/collectiveaccess/providence/install/index.php
    "

    I already customized setup.php-dist and and renamed it into setup.php
    But I kept the file in the same directory: /srv/www/htdocs/collectiveaccess/providence/
    while the index.php file is located in: /srv/www/htdocs/collectiveaccess/providence/install

    and I should be able to open index.php in the web browser, right?
    Did I miss something?

  • Make sure permissions of setup.php are set such that the web server can read it.

  • do you mean values in the first section of the setup.php file?

    THE VALUES BELOW MUST BE CHANGED TO SUIT YOUR ENVIRONMENT:
    CA_DB_HOST CA_DB_USER CA_DB_PASSWORD CA_DB_DATABASE CA_APP_DISPLAY_NAME CA_ADMIN_EMAIL

    I set al of them. more changes I did not perform on setup.php

  • I could solve it, going through the installation an configuration of apache2 and php7 again, with a good tutorial
    I think the problem was a missing php7-mysql and apache2-mod_php7. I had just installed php7...
    thanks for you help!

Sign In or Register to comment.