Cant enter LCSHs or any other details within a textbox that has a grey arrow pointing downwards.

I attached a photo showing how the textbox looks, but I can't save any entered data within any textbox that has a small, downward pointing arrow. When I type, a small grey circle appears, then it disappears and is replaced with the arrow again. But once I save, the information deletes and does not save...

This problem has made the "relationships" page nonfunctional for me at the moment...

Comments

  • Hi,

    What version of CA are you running? And with what browser? Does this happen in all browsers? And did this ever work for you, or is it a new problem?


    seth

  • edited February 14

    Hello Seth,

    I am back on the Collective Access/Command Line adventure!

    I am running version 1.7.9, the problem is occurring on all browsers (Firefox, Chrome, and Safari), and I recently downloaded CA though the Mac Terminal this month. The problem must have been since my download.

    I found a similar issue that was resolved with a patch, however I can't find the patch from this page:

    https://collectiveaccess.atlassian.net/browse/PROV-2464

  • Hi,

    In your setup.php file can you try adding this line somewhere:

    ini_set("display_errors", "Off");

    Then try doing a lookup again. It may be that PHP is emitting warnings into the request response. This will prevent that and at least tell us that warnings are the problem. If they are then the next still will be to look at the messages and see why they're getting triggered.

  • edited February 14

    Hello,

    This worked like a charm! Thank you!

    My subject headings are now showing as published works?? (I attached an image of what I see) But this was a huge roadblock.



    I figured it out! Go into the collection, then "Manage" > "Administration" > "Metadata elements"

    Organize the list by name.

    Scroll down to Library of Congress Subject headings. Click to Edit it.

    Scroll to "Vocabularies" and use the drop down list to choose the one you prefer. The preferred subject headings will now automatically show.

    (Thank you Seth!)

  • Great. Now we need to figure out what those warnings are. Can you look in the web server logs? Or turn on error messages again and look in the browser console for the errors? We definitely want to fix whatever the underlying problem is.

    Thank you.

    Seth

  • So, I am kind of a Commonad Line newbie... (I learned Linux from a Udemy course not long ago) and I honestly don't know where the web server logs are... I tried to look around a little. Feel free to let me know where they are!

    I'm now going to remove the code you sent me, turn on the error messages, and retry. I'll respond again when I manage to find the errors.

  • edited February 14

    Here are the console errors from the web page - the LCSHs are NOT working in this instance:

  • edited February 14

    Here is a screenshot of the console from the webpage AFTER I add the code you shared with me - enabling the LCSHs to function again. Hope this helps!

Sign In or Register to comment.