trouble upgrading to 1.7.9 or 1.7.10

I'm on windows/IIS and am running 1.7.8 currently. Trying to upgrade following the steps and I just keep getting a 500 error. I have an early 1.7.9 development that I used the same steps for and it runs fine. Any advice?

Comments

  • Hi Sarah,

    Is there anything in the Windows logs about what is causing the 500 error? It's a very general code and has a very wide variety of causes.


    seth

  • Looks like it's 500.0 Module or ISAPI error occurred.

    2021-02-09 00:23:08 127.0.0.1 GET /SMA-catalog3/index.php/system/auth/login - 80 - 127.0.0.1 Mozilla/5.0+(Windows+NT+6.3;+Win64;+x64;+rv:80.0)+Gecko/20100101+Firefox/80.0 - 500 0 0 140

    2021-02-09 00:27:09 127.0.0.1 GET /SMA-catalog3/index.php/system/auth/login - 80 - 127.0.0.1 Mozilla/5.0+(Windows+NT+6.3;+Win64;+x64;+rv:80.0)+Gecko/20100101+Firefox/80.0 - 500 0 0 78

    2021-02-09 00:28:25 127.0.0.1 GET /SMA-catalog3/index.php/system/auth/login - 80 - 127.0.0.1 Mozilla/5.0+(Windows+NT+6.3;+Win64;+x64;+rv:80.0)+Gecko/20100101+Firefox/80.0 - 500 0 0 62


    For the test version of 1.7.10--I just gave IIS_IUSRS full permissions to the whole providence folder to make sure that wasn't the issue.

  • I got someone to show me how to turn on the more detailed errors in IIS, so I can investigate it some more on my own. Thanks!

  • Yeah, you'll need some more detail. The fact that it's happening when you log in is odd.

    What version of Windows are you running this under? And what version of IIS?

  • Got a message that there was an unexpected ? on utilityHelpers.php line 2891, I deleted it and it gave the screen to change permissions on tmp and log, etc. When I did that, it gives me this error

    PHP Warning:  fsockopen(): unable to connect to tls://localhost:443 (Unable to find the socket transport "tls" - did you forget to enable it when you configured PHP?) in D:\providence1710\app\lib\Controller\Request\RequestHTTP.php on line 660
    


  • What version of php are you running!

  • Also Windows Server 2012 R2 Standard Edition/IIS 8.5

  • edited February 11

    Ah ok. PHP 7.0 is really old. You'll need to update to at least 7.2. (That's end-of-life too, but recently so). Ideally get updated to 7.3 or 7.4.

  • Okay, I'll try that.

  • Let me know how it goes...

  • I updated to PHP 7.4 and got through a few other errors--I got to the screen that told me I need to install openssl or mcrypt. So that's my next step.

  • That's progress. I'd try OpenSSL first.

  • So I enabled openssl in php.ini and I'm getting the same screen. Is it just using the libraries or do I have to do a ssl certificate? I have http in global.conf as the site_protocol.

    Also, looks like mcrypt is deprecated as of PHP 7.1.  

  • What does the screen look like exactly?

  • If you run phpinfo does openssl show as install?

  • Okay, now I have openssl installed and showing in phpinfo--but now I'm back to the original error:


    PHP Warning:  fsockopen(): unable to connect to tls://localhost:443 (No connection could be made because the target machine actively refused it.
    ) in D:\providence1710\app\lib\Controller\Request\RequestHTTP.php on line 660
    


  • In your app.conf file please add this:

    disable_out_of_process_search_indexing = 1

  • That appears to have fixed it so far in my test instance. Thanks!

  • Now I'm getting the screen


    Your database is out-of-date. Please install all schema migrations starting with migration #157. Click here to automatically apply the required updates, or see the update HOW-TO for instructions on applying database updates manually.


    But the Click here doesn't appear to do anything.

    The update HOW-TO for updating manually doesn't seem to be there yet. I went to caUtils help to check if I could run from there and I get this.


    D:\SMA-catalog\support>php bin/caUtils help

    PHP Warning: PHP Startup: Unable to load dynamic library 'php_gmagick.dll' (tri

    ed: ext\php_gmagick.dll (%1 is not a valid Win32 application.), ext\php_php_gmag

    ick.dll.dll (The specified module could not be found.)) in Unknown on line 0

    PHP Warning: PHP Startup: Unable to load dynamic library 'php_imagick.dll' (tri

    ed: ext\php_imagick.dll (%1 is not a valid Win32 application.), ext\php_php_imag

    ick.dll.dll (The specified module could not be found.)) in Unknown on line 0

    PHP Warning: require_once(D:/SMA-catalog/app/lib/core/Logging/Eventlog.php): fa

    iled to open stream: No such file or directory in D:\SMA-catalog\app\plugins\ns1

    1mmServices\ns11mmServicesPlugin.php on line 29

    PHP Fatal error: require_once(): Failed opening required 'D:/SMA-catalog/app/li

    b/core/Logging/Eventlog.php' (include_path='D:\SMA-catalog\vendor/pear/console_g

    etopt;D:\SMA-catalog\vendor/pear/file_marc;D:\SMA-catalog\vendor/pear/pear-core-

    minimal/src;D:\SMA-catalog\vendor/pear/pear_exception;D:\SMA-catalog\vendor/pear

    /archive_tar;D:/SMA-catalog/app/lib;D:/SMA-catalog/app/models;.;C:\php\pear') in

     D:\SMA-catalog\app\plugins\ns11mmServices\ns11mmServicesPlugin.php on line 29


    D:\SMA-catalog\support>

  • The "how to" link needs updating as the site has changed. We'll fix this. It won't tell you anything you don't already know though.

    You should be able to update the schema via the link or caUtils update-database-schema

    By the looks of it you still are using the setup.php from your old install?

  • I noticed that it's still looking for a file in app/lib/core but that folder doesn't appear to exist anymore in 1.7.10

  • I used a copy of the new database setup.php and copied my information over. The caUtils appears to work in the test instance when I set the collectiveaccess_home to it. Perhaps I somehow missed copying over that support\bin folder. I'll try again when I get the chance. The link didn't seem to do anything--i waited 30 minutes and it didn't load a new page or anything.

  • No worries on the link. It seems like the install is working now though?

Sign In or Register to comment.