Problems copying occurrences in 1.7.11

edited April 9 in Pawtucket Help

When I try to copy an occurence I get the following error message (in red at the top):

Could not duplicate movement_event: '' is not valid for Collection.

In 1.7.8 and 1.7.9 I could copu occurences with the same copying settings without error. What could cause this?

(Especially curious about the " not being valid)

Comments

  • I am sorry, I did change the copying settings, so the only remaining question would be what the "not being valid would mean

  • It implies the value for the movement_event field is blank, and blank values are not allowed.

  • I would think the collection (related collection) field would be empty, but the fact is it is not. There is a related collection in the occurence.

    I tried to duplicate the behaviour int the Collective Access Demo site, but there I find no problems duplicating an occurrence.

    The same for a 1.7.11 test install on my local system with default profile.

    So it seems to be related to my installation profile. Any suggestion where to look for the error? Would it be in the collection types?

    I have attached a screenshot for my duplication tool settings.

    785 x 1003 - 114K
  • Can you send me your profile?

  • Hello Seth,

    I have attached it as a zip file.

    You also (still) have acces to my online test installation.

  • Could this be related to my problem (which is solved) with collections not showing in Pawtucket?

    (https://collectiveaccess.org/support/index.php?p=/discussion/300739/1-7-11-pawtucket-collections#latest)

    That was caused by the idno collections (changed it into to collection) in my lists --> collection_types -->Collection item

  • I have checked back trough versions (with my current settings for duplication in my preferences) and found the problem occuring first with 1.7.9.

    In 1.7.8 there was no problem copying occurrences with these settings.

  • edited April 20

    I think I have found the problem (still looking for the solution).

    It seems to be related to multipart_id_numbering. The error for the blank value not being valid is pointing to the collection part of the numbering, not to the related collection

    I have this setup for occurences:

       ca_occurrences = {
          __default__ = {
             separator = ,
    
            #sort_order = [PROJ_Name, PROJ_collection, PROJ_number],
    
             elements = {
                PROJ_Name = {
                   type = CONSTANT,
                   value = PROJ,
                },
                PROJ_collection = {
                   type = LIST, 
                   values = [SKU, _RU, UMC], 
                   default = UMC, 
                   width = 3, 
                   description = Collectie code, 
                   editable = 1,
                },
                PROJ_number = {
                   type = SERIAL,
                   width = 8,
                   zeropad_to_length = 5,
                   description = catalogusnummer, 
                   editable = 1,
                   table = ca_occurrences,
                   field = idno,
                   sort_field = idno,
                }
             }
          }
       },
    

    If I disable this copying works fine.

    I have (practically) the same setup for objects (without the first constant) an Loans.

    The both copy just fine.

    Now the next task is to find the cause of the error......

  • I'll look into this today

  • Hello Seth,


    Thanks. I also checked the behaviour of my multipart_id_numbering file in a local setup (1.7.11) with default profile.

    That did not give any issues copying the occurence, so it is probably still profile related

Sign In or Register to comment.