Strict_types warning and syntax error when installing

I am trying to install Collective Access on my web server, for which I've set up a subdomain. I configured PHP as version 5.6 since it supports all the extensions listed in the documentation but version 7.1 and higher do not support MySQL. I set up the SQL database and user, updated the setup.php file, performed all the other steps in the documentation, and copied the Providence files to the root of my subdomain. However, when I run install, I get this error:

Warning: Unsupported declare 'strict_types' in [location]/vendor/sabre/uri/lib/functions.php on line 3

Parse error: syntax error, unexpected ':', expecting '{' in [location]/vendor/sabre/uri/lib/functions.php on line 23

I imagine that if there were a problem with the code others would have hit this snag before and wouldn't have been able to install version 1.7.11, so I must be missing something. I tried using PHP version 5.5 and got the same error, and with version 7.1, I instead got this error:

Parse error: syntax error, unexpected end of file, expecting function (T_FUNCTION) or const (T_CONST) in [location]/app/lib/Print/phpqrcode/qrinput.php on line 420

Does anyone have any leads for me?

Thanks!

Comments

Sign In or Register to comment.