Pawtucket2 Image Overlay Issues

I have read several support forum posts on this same topic but still have had no luck rectifying it. When clicking on an image in Pawtucket the overlay loads but no image shows up, it's just blank [see screenshot]. I have tried reprocessing media, updating the IIIFController.php file in Pawtucket, changing the viewer to TileViewer, UniversalViewer, and Mirador in the media_display.conf file in our theme and reprocessed after each change. Nothing seems to have an impact. The overlay works just fine in Providence, we only have an issue in Pawtucket.

We are running on a Centos 7 server, Providence version 1.7.11, Pawtucket2, with an ISAD(G) installation profile. The issue is occurring in both firefox and chrome.

Here are the relevant snippets from our media_display.conf file in our theme:

detail = {                                                                                                                     

images = {                                                                                                                     

mimetypes = {image/jpeg, image/tiff, image/png, image/x-dcraw, image/x-psd, image/x-dpx, image/jp2, ima$              

display_version = large,                                                                                               

alt_display_version = medium,                                                                                          

viewer_width = 100%, viewer_height = 100%,                                                                             

no_overlay = 0,                                                                                                        

use_universal_viewer_for_image_list_length_at_least = 12,                                                      

download_version = original,                                                                                                                                       

viewer = TileViewer                                                                                            }, 


media_overlay = {                                                                                                              

images = {                                                                                                                     

mimetypes = {image/gif, image/jpeg, image/tiff, image/png, image/x-dcraw, image/x-psd, image/x-dpx, ima$               

display_version = tilepic,                                                                                             

alt_display_version = large,                                                                                           

viewer_width = 100%, viewer_height = 100%,                                                                             

download_version = original,                                                                                                                              

viewer = TileViewer,                                                                                                   

use_universal_viewer_for_image_list_length_at_least = 4                                                        },    


We'd really like to get this rectified. At this point I don't care what viewer we use as long as it works.

Thanks,

Magnus

1761 x 907 - 388K
«1

Comments

  • Can you share a link to the site so I can see the behavior for myself?

  • Unfortunately IT has our ports closed until the site is ready for launch, so there's no public link to share.

  • Could you send me your theme then? As a zip file to seth@collectiveaccess.org.

  • we can see the image but it never completes the clean up

    cleans up the image above the yellow line and stops

    1358 x 879 - 859K
  • Just wanted to check in on this after sending you the zip file last week Seth. Do you know what's causing the overlay issue?

  • I have not had time to look at it.

  • As an addendum to this the image overlay is now working after reprocessing again. I have no idea what the issue was or what resolved it as nothing was changed from the media_display.conf file snippets that I included in my original post. Unfortunately, we are now not able to load PDFs properly with either TileViewer, UniversalViewer, or Mirador. I'm not sure why as they were loading just fine when we were having the image overlay issues. With TileViewer the thumbnail appears fine, but upon opening the viewer we're getting the "unable to load tilesource" error that we're also seeing in UniversalViewer. I have included screenshots for reference. Mirador is pretty seriously glitching, as can be seen in the screenshot, so it's unclear what exactly is the issue here.

    Here is what we have in the media_display.conf file for PDFs

    detail = { pdf = { mimetypes = {application/pdf}, display_version = tilepic, alt_display_version = mediumlarge, width = 400, height = 400, download_version = original, no_overlay = 0, viewer = TileViewer },  }, 

    media_overlay = { pdf = { mimetypes = {application/pdf}, display_version = tilepic, alt_display_version = mediumlarge, width = 100%, height = 100%, download_version = original, viewer = UniversalViewer },

    download = { pdf = { mimetypes = {application/pdf}, download_version = original, viewer = UniversalViewer },


    Thanks in advance.

  • Have you changed media_processing.conf at all?

  • No I haven't. I even replaced it with what was in github and reprocessed everything and am still having the same issue with the PDFs.

  • I've updated Providence and Pawtucket to 1.7.12, reprocessed everything, and we're still having the same issue with the PDF viewer. We no longer have media_display.conf or media_processing.conf files in our theme so that can't be causing the issue. The only other thing I can think of that could be causing a problem is that our providence and pawtucket instances are on different servers. Everything gets ingested and processed on the back-end providence server and then replicated to the front-end pawtucket server.

  • Here's the console error I'm seeing:

    No TileSource was able to open undefined [object Object] openseadragon.js:11361:15

        determineType https://sacda.ca/assets/universalviewer/dist/uv/lib/openseadragon.js:11361

        getTileSourceImplementation https://sacda.ca/assets/universalviewer/dist/uv/lib/openseadragon.js:8803

  • Make sure all of the media files are present on the front-end server, including the "tilepics" directory within your media directory.

  • The tilepics directory is showing up in our media directory. I set the permissions recursively for the directory again and that seemed to fix the tilesource error for really small PDFs that only have a few pages but all the rest are still showing the same error.

  • We still need to fix this issue unfortunately. PDFs larger than a few pages aren't working at all and if you click on the zoom button on any PDF file we get the issue pictured in the screenshot. Any guidance?

  • Hi, I have a problem with some picture that didn't display correctly.

    In providence and pawtucket, when I click on a picture to open it, it's displayed upside down and in mixed tiles ! (see attached pic)

    Have you already got that problem?

    1817 x 587 - 202K
  • What version are you running? There are issues with EXIF orientation tag handling with GMagick and in some cases IMagick that are resolved in the current master branch code. This will be wrapped in a 1.7.15 release later today (maybe tomorrow depending upon how the stars align).

  • Hi,

    I have version 1.7.13.

    I will wait for new version then, hoping that it will solve the problem.

    Thanks Seth.

  • Hi,


    Do you know when 1.7.15 will be released?

    Or is there already a patch that I can install?

    Thanks

  • edited June 13

    You can pull 1.7.15 from git right now if you want. We're still testing one significant change around PDF generation though, so there won't be a formal release until end of day today. A significant security issue was found in domPDF, the library used by CA to generate PDFs. Updating to the latest patched version of domPDF breaks PDF generation, because of changes in how it allows external files to be included. This means changing how we generate output.

    If you pull the 1.7.15 in git at the moment, you may not be able to generate PDFs in all cases. The current state of things appears to be functional, but we're not totally done testing yet. Just keep that in mind if you do decide to do a pull today.

  • Hi Seth,

    I installed version 1.7.15 but problem is still there, picture is displayed upside down and tiled :-(

    933 x 777 - 201K
  • You'll have to reprocess the media to see a difference. To try one image, just reupload it. To fix many run the "reprocess-media" command in caUtils on the command-line. Eg from a command-line on your server run (assuming your in the support/ directory in your install:

    bin/caUtils reprocess-media

  • I tried a reload of one image and display is good but reprocess-media didn't change anything for the others.

    Is there a parameter to add to force the reprocess?

  • The command is there to force reprocessing. What happened when you ran it? What did you see?

  • Here is a printscreen. It looks for files that don't exist in media. There are 30 records in ca_object_representations and I see 30 errors.

    Media directory is not directly under providence : there is a symbolic link between media in Providence and the media directory placed on another partition with more place.

    1705 x 921 - 604K
  • It looks like you don't have permission to write into the media directory. Try running the command as a user with write permissions to the media directories, or change the media directory permissions temporarily to allow your login to write into them.

  • is it a write problem or something else?

    It says "Unable to open file (/var/www/virtual-collections.naturalsciences.be/htdocs/providence/media/virtualcollections/images/5/97213_ca_object_representations_media_582_large.jpg)"

    but that file doesn't exist in images/5.

  • I would guess it can't write to it. I can't tell for sure from here.

  • Hi Seth,

    There was indeed a write problem. Rights were not good on the media directory which was a symbolic link.

    Now Pictures are displayed correctly after running reprocess-media.

    I try to display them with mirador. In Providence, I think it's good but in Pawtucket, it stays with universalViewer! I modified media_display.conf. Is there another place where I should modify parameters? I add in attachment a display in providence (1), in pawtucket (2) and media_display.conf of pawtucket.

    1903 x 887 - 332K
    1895 x 905 - 272K
  • Make sure you've modified all entries in media_display.conf. That PDF is hard to read, but it looks like you missed some.

  • I can't add the file as attachment, so I give you the content here:

Sign In or Register to comment.