HELP!!! Version 1.7.11 search not working as before

I am having a huge problem: I switched to v.1.7.11 from v1.7.8. I made, as suggested, a reindex (with a few issues - I had to update MySQL to v.8).

Now, I can ONLY make general search on one term: multiterm searches as "Vaso Etrusco", that in previous version returned results, now return nothing.

Also, searching on specific fields, always return nothing.

What is really changed in the search?

Please help!

Comments

  • Do you have a local (ie. custom) search.conf file? If so take a close look at it. If you have indexing_tokenizer_regex or search_tokenizer_regex set in the custom file comment them out and reindex. I've seen installs where the indexing regular expressions were set to incorrect values that worked in older versions but no longer work now. By removing them from the locale search.conf the stock ones from 1.7.11 will be used, which will at least give you a baseline to test with.

  • This tip helped me a lot. (but i am not original questioner)

  • Yes, me also... Sorry for late replay, but it worked. Put double bkackslash instead than only one.

    After that, I can say that is not mandatory to rebuild search indexes when upgrading to .11 to make CA working, but it probably is a good practice to solve some indexing issues.

    Am I true?

  • It can't hurt.

Sign In or Register to comment.