Media won't upload?

I am trying to add jpeg images that are around 3mb each, but the images won't show or save. When I click save, the file name simply disappears and not images show.

Any recommendations?

Comments

  • Here is a screenshot of the console as well:

  • edited May 25

    Ok.... still no solution but I think I'm closer.

    I found this old thread:

    https://collectiveaccess.org/support/index.php?p=/discussion/300202/images-not-showing-in-the-front-end-at-all-providence

    I changed the paths of GraphicsMagick and Image Magick to just be "/usr" and this didn't work. So I changed them back, after making sure that they were truly there - which they are.

    I have checked the permissions and they are all set to root... my CA information within "cd /var/www/html/ca" (password, user and such....) are set to "rachael" instead of root.... So I am going to try changing the CA settings now to root.

    I followed the installation here: https://manual.collectiveaccess.org/setup/install/Ubuntu_20.04.html and had no problems with any of the steps.

  • Alright, I changed CA user to 'root' and that didn't work. It crashed my site, so I changed it back to "rachael"

    I then tried adding permissions:

    "sudo chown -R www-data /usr/bin/gm"

    "sudo chown -R 755 /usr/bin/gm"

    This also didn't work.... and now I have no idea what to do from here...

  • What does your configuration check screen show? Also can you send me the output of phpinfo()?

  • Morning, Seth.

    I found a key thing today.

    Photos under 2MB will load, but nothing larger. It has something with the size limit, so I'm about to dive in the installation instructions and look at the "set max limit" part, and will then search through support forum to try and find how to change the upload limit if I still can't figure it out.

    Included below is the phpinfo() in a text file. I hope that is what you are looking for... (I am an archivist, not really a formal programmer!)

    And thank you for answering.

  • edited May 26

    Ok... here is my update.

    I am sure the issue is that php.ini file. I have changed things to this:

    memory_limit = 256M

    upload_max_filesize = 200M

    post_max_size = 250M

    however, when I restart apache2, the changes don't reflect in phpinfo(), even though they are clearly in the php.ini file, saved.

    I don't know if it is because there is a typo preventing the code to change, or if more coding in the terminal is needed. I've googled all afternoon, but I feel like I am close to the solution.

    My latest phpinfo() file is posted here, though it seems no different than the last one I posted... :

  • Which file did you edit? The primary command line one is at /etc/php/7.4/cli/php.ini according to your phpinfo. But the one for the web server will be elsewhere. Is there one at /etc/php/7.4/apache2/php.ini?

  • edited May 26

    So, I installed the locate command and found multiple php.ini files:

    /etc/php/7.4/apache2/php.ini

    /etc/php/7.4/cli/php.ini

    /usr/lib/php/7.4/php.ini-development

    /usr/lib/php/7.4/php.ini-production

    /usr/lib/php/7.4/php.ini-production.cli

    I edited both of the first two php.ini files (cli was already edited, so I changed the apache2 one, and then I restarted), and now the phpinfo() file is reading correctly, but I still can't upload JPEGs over 2mb...

  • Last comment of the day...

    I changed every file I listed to have those 3 parameters.

    /etc/php/7.4/apache2/php.ini

    /etc/php/7.4/cli/php.ini

    /usr/lib/php/7.4/php.ini-development

    /usr/lib/php/7.4/php.ini-production

    /usr/lib/php/7.4/php.ini-production.cli

    It still doesn't upload photos above 2mb. (I can't believe it)

    I am going to upload all other metadata that I can tonight, and hopefully my fresh brain will see the solution tomorrow.

  • Well the settings seem fine, at least in terms of phpinfo output. If you want me to take a look at the machine get in contact with access details at seth@collectiveaccess.org.

  • edited June 10

    Was a solution ever identified for this? I am encountering a similar issue.

    ETA: Nevermind! Changing php.ini worked!!

Sign In or Register to comment.