User Interface Problem

Providence 1.7.11

I hope someone can shed some light for me. I have created five user interfaces for specific data entry forms. Two of these show perfectly on creating a new record. Three do not at all even though the type restrictions are set correctly and show up in Preferences settings correctly. The three images below illustrate. There are no media or relationship screens define for the Artifact form, but when I attempt to create a new Artifact record I get only a screen with Media and Relationships screens.

Having had success with two previous UI, I can't figure out what has gone wrong with the new Artifact, Model, and Report UI, which are all showing the same problem.

Thanks for whatever assistance you can give,

Mark

1241 x 526 - 185K
1583 x 1612 - 436K
1679 x 967 - 202K

Comments

  • I just realized this problem started after we moved from 1.7.9 to 1.7.11! Seth, please help!

  • edited July 13

    Have you cleared the cache after updating? (it should do so automatically, but you never know).

  • Yes. Everything is cleared at every level. Fresh as a daisy. The UI forms created before the upgrade work fine. Can't create new UI forms and assign them to a menu item, even though setting are correct, as shown in images above. We am dead in the water here.

  • I have no idea. Sorry.

  • I looked at the installation profile. It appears there is an error in it that I cannot explain.

     <userInterface code="object_ui" type="ca_objects" typeRestrictions="data_type_periodical" includeSubtypes="0">

         <labels>

           <label locale="en_US">

             <name>Object editor</name>

           </label>

         </labels>

         <screens/>

       </userInterface>

    Says it is looking for <screen>, but I think there is a chunk of code missing.

  • I exported the current profile to create a sandbox installation for testing this error. By removing the section of code above from the export XML file I was able to create a new Providence installation where the menu items/UI worked correctly. Does anyone know how I can change whatever is creating this error within my existing installation?

    Thanks,

    Mark

  • The chunk of code is an editor without any screens, restricted to the data_type_periodical type. If you delete it from your running system you should be ok.

  • Yes, and when I did the site worked fine right up to the point where I imported the database backup. Then right back to the wrong screen. So somewhere, somehow the database screws up the CA installation when creating a new user interface. I am SO frustrated.

  • This is definitely a corruption in the database. A completely fresh install works perfectly. Add the data from a backup, and it stops.

  • Send me a dump of the ”corrupted” database and I’ll try to fix it for you.

  • Thanks a lot, Seth. I appreciate your time. 30 years ago I was a formidable programmer. Now I feel like roadkill with these basic problems I can't seem to sort out.

Sign In or Register to comment.