Object dimensions

Working to try and get dimensions to come out as, for example, 12"L x 5"W x 1"H.

I've followed the suggested code from the documentation: ^ca_objects.dimensions_width L x ... etc

However, I've used ^ca_objects.work_dimensions as that is what my install profile uses, which gives me the entire dimensions like this: 12"; 5"; 1".

I've tried ^ca_objects.work_dimensions.width and ^ca_objects.work_dimensions_width and ^ca_objects.dimensions_width and none of those show up just the singular value. I've double checked what the metadata element is in my install for them:

 <metadataElement code="work_dimensions" datatype="Container">

...

       <metadataElement code="dimensions_width" datatype="Length">

...

       <metadataElement code="dimensions_height" datatype="Length">

...

       <metadataElement code="dimensions_depth" datatype="Length">

Later on, the placement code is specified as:

 <placement code="ca_attribute_work_dimensions">

             <bundle>ca_attribute_work_dimensions</bundle>


Wondering if I could get some help from anyone whose dimensions are coming out fine.

Comments

  • Just kidding, figured out the dimensions. Somehow was doing every combination but the one that worked:


    ^ca_objects.work_dimensions.dimensions_height


    All is well!

Sign In or Register to comment.