Pawtucket shows no photos and says no facets are found

Hello! I have installed pawtucket once before and have it fully functioning. I’m now doing it again, but for some reason it’s not working. I’m not sure what I’m doing wrong… here are all my steps so far:

Pawtucket: 

1. locate php.ini

find ~/ -type f -name "php.ini"

2. Go to where the PHP file is (the apache2 folder)

cd etcphp/7.4/apache2/

3. Enter to configure the PHP files

Sudo nano php.ini

4. Check that the memory_limit is set to 128 

Change change display_errors to “On”

5. Return to the Collective Access file

cd varwww/html/ca 

6. Copy Pawtucket2 from github, into a directory called pawtucket within the Providence

git clone http://github.com/collectiveaccess/pawtucket2.git pawtucket

7. Go into pawtucket2, then copy Pawtucket’s setup.php-dist file to a file named setup.php in the same directory.

cd pawtucket

sudo cp setup.php-dist setup.php

8.Edit setup.php and change the user, password, and database to match your Providence’s setup.php file.

sudo nano setup.php-dist

**make the changes

9. Give permissions on the providence’s /app/tmp directories

sudo chown -R www-data app/tmp

sudo chmod -R 755 app/tmp

10. Make a media folder within Pawtucket

       sudo mkdir media

11. Give permissions to the media folder to be writable by the web server

sudo chown -R www-data media

sudo chmod -R 755 media

12. Make a symlink between Providence’s media folder, and Pawtucket’s media folder:

cd /var/www/html/ca

sudo ln -s /media ~/pawtucket/media

**This is when I saw the errors appear. See the attached photo (ignore the “media” error. I fixed that, and the steps are listed just above)

Error 1: make the Serializer folder writable as well:

cd pawtucket/vendor/ezyang/htmlpurifier/library/HTMLPurifier/DefinitionCache

sudo chown -R www-data Serializer

sudo chmod -R 755 Serializer

 Error 2: make a collectiveaccess directory within pawtucket’s media folder and make it writable

cd /var/www/html/ca/pawtucket/media

sudo mkdir collectiveaccess

sudo chown -R www-data collectiveaccess

sudo chmod -R 755 collectiveaccess

 **I Can now see pawtucket, but no photos appear, and the software says “no facets found”. Any ideas?

Comments

  • I'm not sure why you would need to create the collectiveaccess directory within the linked media directory. You should see the same structure within pawtucket's media directory as providence's....after all, it a link to /providence/media. Might your problem be related to this?

  • edited September 22
    1. I tried deleting the pawtucket/media/collectiveaccess folder and the error message returned, saying to create it again. (See the Photo_A)
    2. Then, I recreated it, reloaded Pawtucket, and the screen said the collectiveaccess folder still needed to be writable. So I did that.
    3. Then, I got the same home screen as before for Pawtucket (no photos or clickable links, see Photo_B)
    4. If I go to browse, I see the items, but no media (see Photo_C)
    5. And if I go to the console from the browse screen, then I see these error messages (see Photo_D)

    I do notice that there are 12 error messages - which corresponds with the 12 items that are missing a photo icon entirely in the browse screen.

    ALSO, I will add that it's interesting to see which photos dont have an image icon. Because, they are photos which were originally uploaded without media. Though, I have added media to them and they show on Providence. Yet Pawtucket doesn't seem to recognize the changes from the original upload. Could this mean it's a symlink issue? Or maybe with mysql?

    Sorry for all this information…. I hope some of it is helpful. I’m going to keep fiddling when I get home from work (6pm/18:00 eastern time). Let me know if you have any other ideas, and thank you for your time!

    2462 x 996 - 2M
    2368 x 1456 - 2M
    1700 x 1390 - 1009K
    1648 x 1188 - 2M
  • Final update for my day:

    I just went into my other Ubuntu system, the one that has a WORKING version of Pawtucket, and the pawtucket/media directory looks like this. (See FamilyArchive photo)

    Then on the ubuntu that is not working, it looks very different. (See HeritageSociety photo).

    I have a feeling that I did this in my first installation: cd /vae/www/html/ca/media /var/www/html/ca/providence

    When I get home, I am going to delete the pawtucket/media directory, copy the Providence one in, and proceed.

    If that doesn't work, I may just delete the whole Pawtucket installation from the CA directory and try again from scratch. I'll let you know if anything changes.

    804 x 546 - 278K
    928 x 490 - 224K
  • OMG.... it worked!!!! Fixed with 3 lines of code. No re-installation needed.


    1.Go to ca/pawtucket

    cd /var/www/html/ca/pawtucket

    2.Remove the media directory I created there

    sudo rm -fr media

    3. Copy the media directory from ca into ca/pawtucket

    cp -rp /var/www/html/ca/media /var/www/html/ca/pawtucket


    The symlink didn't get removed during the process, and everything is fine now.

Sign In or Register to comment.