How to remove index.php from URL?

I tried to set __CA_USE_CLEAN_URLS__ to 1 before or after installation, neither works. It just break CA.

What should I do?

Comments

  • You'll need to make sure your web server (assuming it's Apache) has mod_rewrite enabled and allows .htaccess overrides.

  • Thank you @seth. Server is Apache and .htaccess is 644. Is there anything else?

  • You'll need to make sure AllowOverrides is set for the directory CA is in, to allow .htaccess to be evaluated. Or else transfer the .htaccess config to your Apache configuration.

  • Thank you @seth. It is on a managed virtual server and I don't have access to Apache configuration. Contacting the hosting technical support. Is there another solution?

  • Usually on a managed server .htaccess-based overrides would be enabled. Are you sure they're not?

  • Well. I am using Cloudways hosting, and I am actually quite sure .htaccess-based overrides is enabled. Because I manage quite few servers @ this provider.

    Then, question is, why it doesn't work if overrides is enabled. Is it because caching server? I actually disabled Varnish during my test.

Sign In or Register to comment.