Version 1.8(Develop) CaUtils reload-current-values-for-history-tracking-policies PHP errors

I have version 1.8 (develop) installed on both my local server and my live server (And a test version on the live server)

CaUtils reload-current-values-for-history-tracking-policies works fine on my local server and my test system but gives errors on my live system.

The app.conf file with the history tracking policy is the same in all cases.

The error is:

]PHP Fatal error: Uncaught Error: Call to a member function setDb() on null in /home/u31667p26800/domains/radboudkunst.nl/public_html/app/lib/Search/SearchIndexer.php:585
Stack trace:
#0 /home/u31667p26800/domains/radboudkunst.nl/public_html/app/lib/BaseModel.php(3356): SearchIndexer->indexRow(NULL, 1, Array, false, NULL, Array, Array)
#1 /home/u31667p26800/domains/radboudkunst.nl/public_html/app/lib/BaseModel.php(2758): BaseModel->doSearchIndexing(Array, false, Array)
#2 /home/u31667p26800/domains/radboudkunst.nl/public_html/app/lib/HistoryTrackingCurrentValueTrait.php(581): BaseModel->insert()
#3 /home/u31667p26800/domains/radboudkunst.nl/public_html/app/lib/HistoryTrackingCurrentValueTrait.php(746): ca_objects->setHistoryTrackingCurrentValue('current_locatio...', Array, Array)
#4 /home/u31667p26800/domains/radboudkunst.nl/public_html/app/lib/Utils/CLIUtils/Maintenance.php(2176): ca_objects->deriveHistoryTrackingCurrentValue()
#5 /home/u31667p26800/domains/radboudkunst.nl/public_html/support/bin/caUtils(172): CLIUtils::reloa in /home/u31667p26800/domains/radboudkunst.nl/public_html/app/lib/Search/SearchIndexer.php on line 585

Does anyone have a clue what could be causing this?

Comments

  • Try clearing the cache in app/tmp on the server that's throwing this error. It looks like it still has an older (pre-update?) data model stuck in the application cache.

  • Cleared the cache, also ran caUtils clear-caches to be sure,

    The same error still pops up.

  • What is the different between your local, test and live system then? The error implies you have the old data model cached.

  • The differences:

    Local system runs on Windows 10 with WAMP server. It is al light weight (few objects etc.) test system.

    Live Test system and Live system run on the same Shared hosting Linux system.

    Live Test system has an older dataset than the Live system with a few differences due to the creation of test cases.

    In all cases the app/conf/local fiels are the same.

    I have just restored a backup of the Live system and it's database and am trying to install the Update once more.

    (Deleting all files exept for the media folder, the setup.php and my local files and theme and then uploading the new files from providence develop)

    I will post it if this resolves the issue.

  • I am using the develop code downloaded 15-03-2022.

    If I use the develop code downloaded today I cat a similar error on my local test system

  • Ok so it's tied to version. Thanks.

  • Can you send me your configuration for location tracking. I've just confirmed this issue does not occur on our test and production systems using current development code. So my next guess is that it's something with your config.

  • I have attached the (zipped) app.conf file.

    This is for my live and live test configuration.

    I also have a local test system based on Dublin core (app_dublin.zip)

    The live and live test version is an extended version (adapted for metadata differences and relationship differences) fo the dublin core version.

  • Reinstalling the update did not change anything. Error still appears.

    It is probably something in my local app.conf.

    In my live system I also get the error when I use the rebuild-sort-values in caUtils, and the error dissapears if I delete my local app.conf file.

    What still puzzles me is that the same app.conf file with the same location tracking does not cause the issue in my live test system (same server and same configuration) and my local test system (Windows10/WAMPP and same configuration). These both have the same version of providence develop installed, so it seems to me it is not related to the version of providence develop.

  • I'm working on it.

  • Thanks for that. I am also trying to solve this.

    I have tried a new empty local app.conf with only the sample history_tracking_policy from the manual (tried both the workflow based and the movement based example) with the same error as a result.

  • Is there any chance it is related to something in the database?

  • I think I found it:

    In my setup.php I had set the caching method to: define('__CA_CACHE_BACKEND__', 'memcached');

    I changed it to file. Now php bin/caUtils reload-current-values-for-history-tracking-policies seems to run without errors.

  • Yeah, so it was caching. The old model was stuck in there. I'm glad you found it.

  • Yes, stupid. I did not think of that setting in setup.php.

    Thanks for the help anyway.

Sign In or Register to comment.