PHP Fatal error: Allowed memory size of 2097152 bytes exhausted

I tried to get the help printout for:

"caTools help"

"caUtils help"

but I get the error: "PHP Fatal error: Allowed memory size of 2097152 bytes exhausted (tried to allocate 32768 bytes) in /var/www/html/ca/app/lib/Zend/Locale.php on line 1016"


I increased the memory size in app.conf

Variable: dont_use_exif_read_data_if_larger_than =

But nothing changed...

Any ideas?

Comments

  • Hi.

    I hate when this happens. It's not a collective access specific problem. Try increasing the memory limit in PHP.

    1. Locate the php.ini file used by your web server. You can click the "more information" link on Drupal's status page's PHP section. which shows the phpinfo() page. Locate the Configuration File (php.ini) Path row on that page. During installation Drupal checks the PHP Memory Limit, and if it is less than 64M, an error message also provides the path to the php.ini file.
    2. Edit the memory_limit parameter in the php.ini file (usually in a section called Resource Limits). Make sure you use M to specify the number of megabytes (not MB).
    3. memory_limit = 256M ; Maximum amount of memory a script may consume (256MB)
    4. If there is no section already for this, place the above line at the end of the file.
    5. Restart Apache.


Sign In or Register to comment.