Entities' IDs do not autoincrement

Hey everyone! After the last CA update we have noticed that creating new entities does not autoincrement their ID, they are stuck on the last created one, repeating it. I have looked in the Github issues but it seems no one else has encountered this error. Should I send a BR?

Thank you all for your time in advance, Cheers.


  • Are you using auto-incrementing numbers for other record types? Do those still work?

  • Hi Seth! Thank you for your reply. Objects are autoincrementing correctly, I have not encountered reports from the team of other type IDs not incrementing correctly. I just created a test object and it incremented correctly.

  • What version are you running?

    What thing to try regardless of version: go to Administration in the Manage menu, then select Maintenance from the side menu and then use the option to rebuild sort values. And then try creating an entity again. If this doesn't help, please let me know what version you're running and send or post your multipart_id_numbering.conf file so we can see the configuration your are using.

  • Excellent, I'll get back home later today and I will let you know how it goes. Thanks!

  • Hey Seth! This has worked wonderfully, the issue is solved.


Sign In or Register to comment.