How to configure the type_facet for object browse?

I need help in configuring object-type as a filter to browse the objects in the collection.

Right now, the relevant portion of the file pawtucket/app/conf/browse.conf looks like this:

type_facet = {

         type = fieldList,

         field = type_id,

         group_mode = none,

         label_singular = _("object type"),

         label_plural = _("object types"),

         description = _("Find objects according to the Types defined in your collection profile."),


I guess I need to touch up the above to activate object-type as a filter to browse objects.

What should be done to achieve that?


  • edited February 6

    Hi Parasmoni,

    You have to check in Manage --> Lists and vocabularies --> Objects Types if all the types you want to display are set to "accessible to public".

    Also, check in pawtucket/theme/Your_Theme/conf/browse.conf if this file does not overwrite other directives.

  • Thank you darrigan, for your prompt response and for rescuing me once again. Your first suggestion worked like a charm.

    I have one more issue regarding browsing. The items in the navigation menu Browse>> Objects>> Browse by>> (Object types, People, Places, Terms, Collections, etc) remain inactive all the time. Nothing happens on clicking them. However, the 'Browse all objects' button works nicely.

    For your convenience, I tried to illustrate my problem in the image attached.

    1920 x 515 - 141K
  • edited February 6

    Do you have some objects, peoples, places... set to "accessible to public"?

    And are those objects related to other objects, peoples or places? If not, there is no reason to browse objects regarding to other elements. Or maybe related elements are not "accessible to public". Check that 😉

    I remember when I installed Pawtucket, 5 years ago, I was lost 😉 The display of the Browse menu was not my taste, so I customized it. For example, in browse.conf, I set: browseMenuFormat = list

    Don't forget to delete Pawtucket's cache files sometimes... (all files in pawtucket/app/tmp/)

  • Setting browseMenuFormat = list has solved my problem. Thank you darrigan 🙏

Sign In or Register to comment.