Can I view original files only


I have this setting on Providence 1.7.17 where I need to minimize the media processing for video files of types quicktime and windowsmedia .

I tweaked the media-processing so I can avoid creating hi_265 version . And I set display_version in media_display.conf to be (original) but It's not working !

After I upload the media and performe the caUtils process-task-queue The media viewer only shows the poster but no video is even linked !

Can videoJs play these kind of files or should I re-encode them by media-processing.conf ?



  • You may have misconfigured your media_processing.conf and/or media_display.conf. Please post them.

  • Thanks for the reply...

    After I post this discussion and before you reply, I was still discovering the configuration of media_processing.conf and media_display.conf. And I was unaware of the multiplicity of codecs used in my videos. So I was thinking the videoJS could play such diverse codecs, but I learned it was not possible.

    ... to get the full picture I need to explain a bit more :

    I have terabytes of media in an old archival system (Server A) with different formats, video, images, and pdf where the most contributor to the size is the video. I have Providence and Pawtucket running on a vm (server B). Both servers are on the same local network ... So I was thinking about the best scenario where the goal is to create a demo archival system based on the powerful technology of collectiveaccess, without the need to copy all the media from (server A) to (Server B)

    so what I did was :

    1) tweak the media_processing to create h265 version of all videos.

    2) batch-imported the media using "caUtils import-data" with media url field ( pointing to the media at server A)

    3) run a caUtils process-task-queue to run the required ffmpeg and other processing

    I tested the result and it worked fine with regard to display. since the media_display.conf (display_version) was set to h265.

    However, when I download a file, it downloaded a (0 kb) file of the video! In the log file, there was this error every time I try to download the media

    "ERROR --> ApplicationException: File for download does not exist"

    I suspect that the url of the original version is not the url of the media at (Server A) . Since I tried to reach the media using the URLs on the browser directly and the browser reached them !

    Attached are the media_processing.conf and media_display.conf , I changed the files extensions to txt . otherwise the attachment do not work.

Sign In or Register to comment.