Advanced Search form: No option in the "Type" drop-down list.

In the Advanced Search form, the drop-down list for object types is not working. It does not show any object type option. [see the attached image]. This is despite all object types are made accessible to public.

1278 x 473 - 2M


  • edited April 1


    Did you flush the cache files? (maybe...)

  • Also, make sure all types are marked as accessible to public.

  • I tried all these several times. But the drop-down list for object types is still dead in the advanced search.

  • Check in ca_objects_advanced_search_objects_html.php if the code for this drop-down list is: {{{ca_objects.type_id}}}

  • Yes, the code for the drop-down list is {{{ca_objects.type_id%height=30px}}}

  • Try to remove %height=30px... And flush the cache. (I've no more idea...)

  • I tried this but didn't work. But thank you darrigan for your consistent help.

    In order to explore this, I made a fresh installation of CA in a different machine. In this fresh installation, the drop-down list is working perfectly.

    I wonder if it is possible to replicate the configuration of this fresh and working instance of CA to my actual archival portal?

  • Hi Parasmoni, I never tried what you suggest...

  • I found the solution, rather in an unexpected area. The visibility of the drop-down menu is found to be connected with the Access Control setting of the Providence. In my case, in the Access Roles settings for the Pawtucket, when I changed the Access status for not accessible to public category from Read access to No access, the drop-down menu came back in the Advanced Search page.

    I have attached here a screen shot to explain what I mean.

    Thank you darrigan, for patiently responding to all my queries.

    774 x 467 - 1M
  • Hi, Darrigan and Seth

    I have the same problem for the drop-down list for the object types.

    I have tried all the suggestions above but still not working.

    I add additional field in the advanced search which also have the drop-down list and all not working.

    While I see in the pawtucket demo, the drop-down list for the object types is working.

    Do you already have solution on this? Thanks before!

Sign In or Register to comment.