Fatal Error Allowed Memory

Out of nowhere, both Providence and Pawtucket simply stopped working.

Error from the Providence installation:

Fatal error: Array and string offset access syntax with curly braces is no longer supported in /home/oadarchi/staff.oadarchives.org/app/helpers/utilityHelpers.php on line 347

Error from the Pawtucket installation:

Fatal error: Allowed memory size of 2097152 bytes exhausted (tried to allocate 36864 bytes) in /home/oadarchi/catalog.oadarchives.org/app/lib/Db/DbStatement.php on line 39

We did nothing to any code. First, the rebuild indexes function stopped working. Just times out and the connection drops. Now this. Can someone help out here. This is beyond my understanding.

Thanks for any help,



  • Hi Mark,

    There should have an update of your PHP version on your hosting, to PHP 8.

    You should have a look at https://collectiveaccess.org/support/index.php?p=/discussion/comment/325379#Comment_325379, and after backup (always) migrate to the dev/php8 branch.

  • I got the Providence part working again through resetting the PHP to deprecated 7.4. Pawtucket is not working at all. The Rebuild Search Indices function has stopped working. All the lookups iin date entry that rely on those indices return a blank, and string search returns nothing, as well. I am stumped. Anyone have any suggestions? There are so many customizations I am disheartened to try to upgrade from 1.7.14.

  • RESOLVED: There were two issues here. One was the deprecated PHP 7.4, and the other was a setting on Bitdefender. The Rebuild Search Indices function worked on an iMac with Safari but not on a PC with FIrefox. I was able to recover all the data. There is still a search error generated, but another forum post is helping with that.

Sign In or Register to comment.